View Single Post
  #1  
Old 27th May 2007, 20:57
jake jake is offline
Junior Member
 
Join Date: Oct 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default Still errors with Openssl on Etch

Hello,

First off, thank you for a great piece of software. I've been using ISPConfig for 6 months now, and I found a very easy to use! A great tool.

Recently i've tried to upgrade the installation to the latest version but there something went wrong. So i decided to reinstall my (virtual server). But whatever i try the install seems to go wrong everytime.

I've tried to change the line in compile_aps/compile as described in one of the other topics, but when i do that, i'm able to go to certifcate generation. But this generation takes forever. I've let it run for 24 hours, but it was still busy.
If i don't change the lines i've got the following error:

Here's some info from my system:
Code:
uname -a
Linux broomhilda.hyperactief.com 2.6.17.13-vs2.0.2.1-node-b02 #1 SMP Thu May 17 22:00:00 UTC 2007 x86_64 GNU/Linux
Running debian etch 4.0

I followed the perfect setup as closely as possible (due to having a vserver). I skipped the quota section partially and was unable to install bind9 (has been replaced by dnsutils?) so i installed bind. Perhaps a problem with the sources.list file?

The error:
Code:
gcc -DMONOLITH -I.. -I../include  -DOPENSSL_THREADS -D_REENTRANT -DDSO_DLFCN -DHAVE_DLFCN_H -m64 -DL_ENDIAN -DTERMIO -O3 -Wall -DMD32_REG_T=int -DMD5_ASM   -c -o s_server.o s_server.c
/tmp/ccI8c8VC.s: Assembler messages:
/tmp/ccI8c8VC.s:437: Error: Incorrect register `%rax' used with `l' suffix
/tmp/ccI8c8VC.s:445: Error: Incorrect register `%rbx' used with `l' suffix
/tmp/ccI8c8VC.s:465: Error: Incorrect register `%rdx' used with `l' suffix
/tmp/ccI8c8VC.s:466: Error: Incorrect register `%rbx' used with `l' suffix
make[1]: *** [s_server.o] Error 1
make[1]: Leaving directory `/root/install_ispconfig/compile_aps/openssl-0.9.8e/apps'
make: *** [build_apps] Error 1
ERROR: Could not make OpenSSL
rm: cannot remove `install_ispconfig/.nfs00000000025447870006afb9': Device or resource busy
rm: cannot remove `install_ispconfig/.nfs00000000025448550006afba': Device or resource busy
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
Any help is greatly appreciated, thank you!
Reply With Quote
Sponsored Links