View Single Post
  #3  
Old 26th May 2007, 19:04
swggy swggy is offline
Junior Member
 
Join Date: May 2007
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Thanks, but that didn't fix it ...
  • I did 'yum install php-mysql' and got back 'nothing to do'.
  • Then I found that mysql.so wasn't in the ini file, so I added 'extension=mysql.so' to the bottom of the file as you said, but nothing changed.
  • I then tried moving it to the extensions area instead, but nothing.
  • I also tried adding mysqli.so there, since I'm reading that PHP5 takes mysqli instead of mysql, but nothing.

I can get in through Putty on the CLI with
Quote:
mysql --user=swggy test
...of course that's not PHP, but it does confirm that the username and no pwd gets access.

phpinfo says my config file is /etc/php.ini (which is the file I've been making your changes to), and it says that 'extension_dir=./' - is that OK? The tables at the bottom of the phpinfo report jump straight from 'mime_magic' to 'openssl', so adding the 'extension=mysql.so' doesn't seem to have had any effect...
I also see that I have the following in /usr/lib/php/modules:
Quote:
file:///usr/lib/php/modules/dom.so
file:///usr/lib/php/modules/gd.so
file:///usr/lib/php/modules/imap.so
file:///usr/lib/php/modules/ldap.so
file:///usr/lib/php/modules/mysqli.so
file:///usr/lib/php/modules/mysql.so
file:///usr/lib/php/modules/odbc.so
file:///usr/lib/php/modules/pdo_mysql.so
file:///usr/lib/php/modules/pdo_odbc.so
file:///usr/lib/php/modules/pdo.so
file:///usr/lib/php/modules/pdo_sqlite.so
file:///usr/lib/php/modules/phpcups.so
file:///usr/lib/php/modules/xmlreader.so
file:///usr/lib/php/modules/xmlrpc.so
file:///usr/lib/php/modules/xmlwriter.so
file:///usr/lib/php/modules/xsl.so
So I may be a little further, but not there yet. Any other thoughts?
- thanks.
Reply With Quote