View Single Post
  #9  
Old 22nd May 2007, 03:30
cambo cambo is offline
Member
 
Join Date: Oct 2006
Location: Melbourne, Australia
Posts: 53
Thanks: 5
Thanked 1 Time in 1 Post
Default More info.

HI Falko
Sorry for the delay but I only work on this system 2 days a week.

contents of /var/www/web1/user/web1_kristina/.autoresponder.rc
Code:
SHELL=/bin/sh    # for other shells, this might need adjustment
EMAIL=`formail -zxTo:`

              :0 Whc: vacation.lock
               # Perform a quick check to see if the mail was addressed to us
               #* $^To:.*\<$\LOGNAME\>
               # Don't reply to daemons and mailinglists
              * !^FROM_DAEMON
               # Mail loops are evil
              * !^X-Loop: ${EMAIL}
              | formail -rD 8192 /var/www/web1/user/web1_kristina/.vacation.cache

                :0 ehc         # if the name was not in the cache
                | (formail -rI"From: kristina@industat.com.au" -I"Precedence: junk" \
                     -A"X-Loop: ${EMAIL}" ; \
                   cat /var/www/web1/user/web1_kristina/.vacation.msg \
                  ) | $SENDMAIL -oi -t
Result: updatedb
locate .vacation.cache
Code:
/var/www/web1/user/web1_ian/.vacation.cache
/var/www/web1/user/web1_kristina/.vacation.cache
/var/www/web1/user/web1_myles/.vacation.cache
/var/www/web1/.vacation.cache 
(above is link .vacation.cache -> /var/www/web1/user/web1_admin/.vacation.cache)
Had the same problem with the other 2 users listed as well (ie. When Autoresponder is ticked, NO autoresponce was sent.)
Reply With Quote