View Single Post
  #20  
Old 16th May 2007, 16:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by zenny
Dear Falko:

But how to create a glue record with ISPConfig.
This is not created within ISPConfig. You must ask your domain registrar to create one for you.

Quote:
Originally Posted by zenny
And the output of ifconfig (hosted in the openvz virtual environment) is:


# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:336 errors:0 dropped:0 overruns:0 frame:0
TX packets:3227093782 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3227114968 (3.0 GiB) TX bytes:21963 (21.4 KiB)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:127.0.0.1 P-t-P:127.0.0.1 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
RX packets:47092 errors:0 dropped:0 overruns:0 frame:0
TX packets:54422 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:25121772 (23.9 MiB) TX bytes:21531826 (20.5 MiB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.1.204 P-t-P:192.168.1.204 Bcast:192.168.1.204 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1




The contents of the /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf are:


NameVirtualHost 81.216.XXX.YYY:80
<VirtualHost 81.216.XXX.YYY:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.domain.tld:80
######################################
#
#
<VirtualHost 81.216.XXX.YYY:80>
ServerName www.domain.tld:80
ServerAdmin webmaster@domain.tld
DocumentRoot /var/www/web2/web
ServerAlias aristoli.com www.81.216.XXX.YYY
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web2/cgi-bin/
....
You are using the wrong IP address in ISPConfig. You must use the IP address that you see in the ifconfig output (i.e. 192.168.1.204), not 81.216.XXX.YYY.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote