View Single Post
Old 12th May 2007, 07:43
bluethunder82 bluethunder82 is offline
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Unhappy One Domain Name Not Responding Authoritatively

Hopefully someone here with more linux background can help me with this problem.

I'm running Ubuntu 6.06 with all the latest patches applied

This is a production server that has been working now without any problems since November 06 (went it was setup). This morning I went to try and view a website hosted with the server and I got no response. The computer that I tried to view the website on uses the ISPConfig server for DNS lookups which has been working without trouble. What appears to be happening is that the dns server is not sending an answer when queried. The really strange part is that the other 78 domains on the server are all working without any troubles.

There have been no changes to the server configuration in the last two weeks and prior to that I just applied some patches I verified on my test server.

Here is a run down of what I have tried / observed and hopefully I'm missing something simple.

1) I verified that the name servers were pointing to the correct addresses - no problems.

2) I used my dial-up account to verify if the backup domain names are working - There was no problem viewing the website using a third-party dns server for lookup. Email was also going through but using my secondary DNS server.

3) Running gave me what I expected except it confirmed that the DNS server was not responding for my domain in question. I double-checked a few other domains from the server and they all checked out correctly.

4) I restarted the bind9 server - No change

5) I restarted the server - Didn't expect this to help but it gave me a chance to move the server - No change on startup

6) I tried saving the DNS record again using the DNS manager - No change

7) I tried adding then removing an 'A' record to save - I was hoping this would have the file re-written - No change again.

8) I backed up my original pri file for the domain and removed the original. I recreated the entire domain using the DNS manager again - The file was created again however there was no change.

What is really confusing is why only this one domain name. At this point I have ensured my secondary DNS server will not try to refresh its data so I'm not loosing email for this domain however I am at a loss for what could have caused this. It appears all the other services haven't forgotten this domain name just bind.

Any other ideas?

Reply With Quote
Sponsored Links