View Single Post
Old 10th May 2007, 21:21
Lausch Lausch is offline
Junior Member
Join Date: May 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default I get no emails - Postfix Problem

Hi Guys,

i reinstalled my system now 6 times, i think now its enough i give up.

also google and research in global forums doesn't helped me.

please guys. help me!

The Problem

I cannot get receive any email

my postfix conf:

# See /usr/share/postfix/ for a commented, more complete version

# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = localhost
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination =, ns30****,, localhost
relayhost =
mynetworks =
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all

smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

i tryd many many many and i saw the following maybe helpful things to correct this error.

if i try to call the Maildir Shortcut on my FTP-Root i get an error
if i call the shortcut on ssh it works
maybe this isnt the problem, i just want to say all i now.


my domains seems successful routet to my server

mx are mail.domain.tld

i can send emails and DONT get mailer daemon back
if i want to receive emails i dont get any error just no mails
if i disable the DNS on domain setup i cannot send or receive emails
the sender get mailer daemon back
if i enable DNS for the domain i see the entry on the DNS manager

DNS ip = serverip
mx = my DNS server ns30****
i also tryd the domain and the ip for the mx server

i can login but dont get emails. just only can send
Maildir are always empty

Maildir ist activated!


Please guys, help me, where can be the problem?

i use etch php5 and apache2 used the perfect installation tutorial from howtoforge


Reply With Quote
Sponsored Links