View Single Post
  #2  
Old 7th May 2007, 09:12
octopus octopus is offline
Junior Member
 
Join Date: Apr 2007
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Update

Quote:
Originally Posted by octopus
hello

In my early post of FC6 white php4 an php5 didnít work

I have decided to use debian 4 white php4 and followed the perfect how to.
Than I followed the suphp white php4 and php5

And i installed Ispconfig at the end

now i have same problems :-(


I Get in the apache error

[Sun May 06 17:25:38 2007] [notice] Graceful restart requested, doing restart
[Sun May 06 17:25:38 2007] [notice] Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c mod_perl/2.0.2 Perl/v5.8.8 configured -- resuming normal operations
[Sun May 06 17:25:38 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Sun May 06 17:25:39 2007] [warn] long lost child came home! (pid 2652)

Than searche (9)Bad file descriptor: apr_socket_accept: (client socket) in the forum

The work around to change this to addhandler? But doest work for me ? and I have debian not suse

$go_info["server"]["apache2_php"] = 'addhandler'; // 'filter' = set PHP filters, 'addtype' = Set PHP addtype or 'both' = Set Filter + Addtype, suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


In the suphp.conf file defind this when *php is called than use php5 and when say *php4 use php4


[handlers]
;Handler for php-scripts
x-httpd-php=php4:/usr/bin/php4-cgi
x-httpd-php=php:/usr/bin/php5-cgi

Help Ö
Iam die hard white reinstalls hahaha

Last night i have reinstall the server again.

but white no ispconfig and no suphp only debian 4 white php5 and the php4

http://www.howtoforge.com/apache2_with_php5_and_php4


That works fine ! i can excute both :-) than i install ispconfig and the first look it works but after 1 or 2 excutes i get again error

[Sun May 06 22:59:34 2007] [error] an unknown filter was not added: PHP

and

[Sun May 06 22:57:49 2007] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)


but white out the suphp i get unknown filter the most
Reply With Quote