Thread: mail problem
View Single Post
  #14  
Old 23rd April 2007, 22:09
docuweb docuweb is offline
Junior Member
 
Join Date: Apr 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Did you guys ever get to the bottom of this issue?

I just loaded a brand new Suse 10.2 + ISPConfig and everything works *except* sending mail from a client outside of the machine. Webmail send & receive works fine, I can download to Outlook Express, but i can't send using OE.

I get the following error message:

Quote:
"The connection to the server has failed. Account: 'mail.justpink.ca', Server: 'mail.justpink.ca', Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10060, Error Number: 0x800CCC0E"
When I tail the mail log, I do not see a connection for SMTP, but I see POP logging on, no problem:

Quote:
Apr 23 14:00:38 arch postfix/master[21631]: terminating on signal 15
Apr 23 14:00:39 arch postfix/postfix-script: starting the Postfix mail system
Apr 23 14:00:39 arch postfix/master[22002]: daemon started -- version 2.3.2, configuration /etc/postfix
Apr 23 14:02:28 arch pop3d: Connection, ip=[::ffff:74.104.228.147]
Apr 23 14:02:28 arch pop3d: LOGIN, user=pennypink, ip=[::ffff:74.104.228.147]
Apr 23 14:02:28 arch pop3d: LOGOUT, user=pennypink, ip=[::ffff:74.104.228.147], top=0, retr=0, rcvd=12, sent=39, time=0
Thinking that maybe my IP wasn't being allowed, I even added my IP block to the $mynetworks.

Quote:
mynetworks = 127.0.0.0/8, 74.0.0.0/8
I have interfaces set to all:

Quote:
inet_interfaces = all
and netstat says it's accepting connections:

Quote:
arch:/etc/postfix # netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 19708/mysqld
tcp 0 0 localhost:asf-rmcp *:* LISTEN 3415/famd
tcp 0 0 *:sunrpc *:* LISTEN 2706/portmap
tcp 0 0 localhost:novell-zen *:* LISTEN 2948/zmd
tcp 0 0 *:hosts2-ns *:* LISTEN 24131/ispconfig_htt
tcp 0 0 199.246.50.101:domain *:* LISTEN 20542/named
tcp 0 0 arch.docuweb.ca:domain *:* LISTEN 20542/named
tcp 0 0 localhost:domain *:* LISTEN 20542/named
tcp 0 0 *:ftp *:* LISTEN 17733/proftpd: (acc
tcp 0 0 localhost:ipp *:* LISTEN 3215/cupsd
tcp 0 0 *:smtp *:* LISTEN 22002/master
tcp 0 0 localhost:953 *:* LISTEN 20542/named
tcp 0 0 *:imaps *:* LISTEN 2833/couriertcpd
tcp 0 0 *:pop3s *:* LISTEN 2822/couriertcpd
tcp 0 0 *:pop3 *:* LISTEN 2806/couriertcpd
tcp 0 0 *:imap *:* LISTEN 2814/couriertcpd
tcp 0 0 *:www-http *:* LISTEN 24199/httpd2-prefor
tcp 0 0 *:ssh *:* LISTEN 3089/sshd
tcp 0 0 localhost:ipp *:* LISTEN 3215/cupsd
tcp 0 0 *:smtp *:* LISTEN 22002/master
tcp 0 0 localhost:953 *:* LISTEN 20542/named
tcp 0 0 *:https *:* LISTEN 24199/httpd2-prefor
Other factors: firewall for both Suse and ISPConfig are disabled. The installation of both Suse and ISPConfig were done to the letter from the manuals. The machine sits forward (no NAT - I have my own class C block) and I have other machines (not ISPConfig, but all linux) that accept SMTP connections so I know it's not blocked at my Cisco. But on most of those I use EXIM, not PostFix. There are no entries in iptables.

Any ideas?
Reply With Quote