View Single Post
  #1  
Old 15th April 2007, 21:58
Leszek Leszek is offline
Senior Member
 
Join Date: Nov 2006
Location: Poland,Włocławek
Posts: 369
Thanks: 22
Thanked 42 Times in 35 Posts
Send a message via Skype™ to Leszek
Default ISPConfig functioning problem ?

Hi!
I finally got a chance to test ISPConfig in action in it's natural environment with a real domain name,on the Internet etc. I wanted it to go quick for now so I used ISPConfig VMware virtual appliance from here.
I've created a new hosting plan and a customer account for my website.Great! It worked!
Next I've added an email account with administrator rights for myself.After some time i've added a coupple of acconts for my friend that helped me in testing from end-user side.Everything worked great but I've noticed that email users have a prefix web2_ prefix.That prefix was attached to an email as a sender name or something and it didn't want it to look that way so according to the faq i removed the prefix.Then it turned out that existing users still had that prefix so i had to remove them,empty the trash and create them again.
This is the point where ISPConfig stopped cooperating.
It turned out that after deleting an email account (with admins privileges) my website dissapeared and SuPHP gave me an internal server error (Uid of script "/var/www/web/index.php" is smaller than Min_uid.I guess that removing an email deleted a system user so that the directory web and everything inside couldn't be owned by the user that doesn't exist.That's an inconvenience to me but I can live with it.I've created an email account with the same username and got a mail account with no prefix.Great!
The site was back again too.I then created the other email accounts for other users.Now every user can send emails but can't recieve them.Anyone that sends an email to any of my users gets a message in return:
"This is the Postfix program at host ok.mbps.pl.

I'm sorry to have to inform you that your message could not be
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<leszek@server1.example.com> (expanded from <my email here>):
[server1.example.com]: Name or service not known"

I don't know why is this happening and how can I change the default address server1.example.com (I though that I've changed it everywhere I should).
Also the php safe mode doesn't work-it's just always off.

ISPConfig version on the appliance is 2.2.3 (I cant update it thru the web interface-it just loggs me out).
Maybe this version of ISPConfig or that virtual appliance is buggy or maybe I am .
Thanks again for Your help.
__________________

Reply With Quote
Sponsored Links