View Single Post
  #2  
Old 6th August 2005, 11:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
Originally Posted by traxxdata
using fedora core 4
installed everything without a prob
when i want start httpd i get this eror in my /var/log/http/error_log
__begin past


unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d': Permission denied
Unable to open logs
[root@vac httpd]#

__end past


looked at ther permissions at those files..
__begin past
[root@vac httpd]# ls -al /root/ispconfig/cronolog
-rwxr-xr-x 1 root root 55866 aug 5 17:58 /root/ispconfig/cronolog
[root@vac httpd]#

[root@vac httpd]# ls -al /var/log/httpd/ispconfig_access_log_%Y_%m_%d
ls: /var/log/httpd/ispconfig_access_log_%Y_%m_%d: Onbekend bestand of map <dutch for unkown file>
[root@vac httpd]#

[root@vac httpd]# ls -al /var/log/httpd/ispconfig_access_log
-rw-r--r-- 1 root root 0 aug 5 17:58 /var/log/httpd/ispconfig_access_log
[root@vac httpd]#

--endpast

it seems to me the parameters %y %d %m are past to cornolog
but if i do cronolog --help %y for example doesnt show..

Even from the ispconfig console under services i am not able to start the normal httpd
https on port 81 runs perfect.

anyone might have an idea of what is wrong? <or what i doin/did wrong ??>

The cronolog line in httpd.conf is correct and the cronolog binary has the correct permissions.

Have you enabled somtehing like SE Linux or any apache directive that permits apache to start piped programs in the /root directory or that are not owned by the apache user?
Reply With Quote