View Single Post
  #1  
Old 24th March 2007, 12:21
jameso jameso is offline
Member
 
Join Date: Nov 2006
Posts: 31
Thanks: 2
Thanked 2 Times in 2 Posts
Default New sites not added to Vhosts_ispconfig.conf? High server loads?

Hi everyone,

I have ISPconfig running on a ubuntu server, and everything has been going well.

The other week I enabled suphp using this tutorial, and modifying the /home/admispconfig/ispconfig/lib/config.inc.php, setting $go_info["server"]["apache2_php"] to "suphp".

Things have been running ok since then, however I have been experiencing high server loads (at least 3), when beforehand the load was usually around 0.2. The server isn't receiving very many visitors.

Top shows that php is using approximately 35% CPU, and there are two or three PHP processes in the top window.

In addition, when I add a new site to ispconfig, I can only see the shared ip message page.

Upon looking in the Vhosts_ispconfig.conf file, no entry is created for the newly added site.

Looking in /home/admispconfig/ispconfig/ispconfig.log shows things such as:
Code:
24.03.2007 - 20:16:44 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 137: cp -fr /etc/postfix/local-host-names /etc/postfix/local-host-names~
24.03.2007 - 20:16:44 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 284: cp -fr /etc/postfix/virtusertable /etc/postfix/virtusertable~
24.03.2007 - 20:16:44 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_postfix.lib.php, Line 289: postmap hash:/etc/postfix/virtusertable
24.03.2007 - 20:16:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1230: cp -fr /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf~
24.03.2007 - 20:16:44 => INFO - HTTPD_SYNTAX_CHECK: suexec
24.03.2007 - 20:16:44 => INFO - HTTPD_SYNTAX_CHECK: suexec
24.03.2007 - 20:16:44 => INFO - HTTPD_SYNTAX_CHECK: suexec
24.03.2007 - 20:16:44 => INFO - HTTPD_SYNTAX_CHECK: suexec
24.03.2007 - 20:16:44 => INFO - HTTPD_SYNTAX_CHECK: suexec
24.03.2007 - 20:16:44 => INFO - HTTPD_SYNTAX_CHECK: suexec
24.03.2007 - 20:16:44 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2417: WARNING: could not httpd -t  &> /dev/null
24.03.2007 - 20:16:44 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2428: httpd syntax seems to contain errors, reloading with old configuration
24.03.2007 - 20:16:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2429: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf /etc/apache2/vhosts/Vhosts_ispconfig.conf_24-03-07_20-16-44
24.03.2007 - 20:16:44 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 2430: mv -f /etc/apache2/vhosts/Vhosts_ispconfig.conf~ /etc/apache2/vhosts/Vhosts_ispconfig.conf
24.03.2007 - 20:16:46 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 706: /etc/init.d/apache2 reload &> /dev/null
24.03.2007 - 20:16:46 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 1891: cp -fr /etc/proftpd_ispconfig.conf /etc/proftpd_ispconfig.conf~
I understand that this means that apache is detecting a syntax error in the newly generated config, and then reloads the old configuration.

Running /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php produces the same result.

How can I go about fixing this problem, or the high loads problem?

I was thinking of disabling suPHP, but haven't been able to disable it and get PHP to work as it was before.

Any help would be greatly appreciated.
Reply With Quote
Sponsored Links