View Single Post
  #7  
Old 10th March 2007, 18:02
jonwatson jonwatson is offline
Senior Member
 
Join Date: Feb 2007
Posts: 176
Thanks: 15
Thanked 2 Times in 2 Posts
Default

Hate to be a bumper, but can anyone help me troubleshoot this issue?

Thanks!


Quote:
Originally Posted by jonwatson
Hello,

I've just discovered that my shell users aren't chrooted. Yikes!

Anyhow, I followed the Howto that Falko pointed to and all seemed to go well, but I'm not getting the desired behaviour. None of my users can log in - they are all greeted with a /bin/bash file or directory does not exist error when they try to log in.

I have enabled the chroot option in config.inc.php and bash does exist in /chroot/home/bin.

I have restarted both ssh and ispconfig_server.

My users from /etc/passwd look like this:

Code:
test.domain:x:1008:1013:test:/var/www/web13/user/test.domain/./:/bin/bash
which looks right to me in that the '.' appears in the right place. I'm not sure why ISPConfig is putting a :/bin/bash after it, though, but I'm not chroot expert by any means so that may be correct.

The user in question has the shell access option checked under his user settings and the web in question has shell access enabled as well.

Any idea where I'm going wrong?

Thanks!

Edit: ISPConfig 2.2.11
Reply With Quote