View Single Post
  #5  
Old 12th November 2005, 21:58
yap yap is offline
Junior Member
 
Join Date: Nov 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok here is my /etc/postfix/local-host-names:

Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
server1.domain1.de
localhost.server1.domain1.de
localhost.domain1.de
www.domain2.de
domain2.de
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
server1
domain1.de
and here the /etc/postfix/main.cf again:

Code:
mydomain = domain1.de
myhostname = server1.$mydomain
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
inet_interfaces = all
alias_maps = hash:/etc/aliases
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
In Yast under network I have server1 as host name and domain1.de as domain name.

And here the error if I send an email from info(at)domain2.de to mail(at)domain2.de over the webinterface:

Code:
Nov 12 20:52:44 linux postfix/smtpd[1697]: connect from localhost[127.0.0.1]
Nov 12 20:52:44 linux postfix/smtpd[1697]: 580C085FE: client=localhost[127.0.0.1]
Nov 12 20:52:44 linux postfix/cleanup[1700]: 580C085FE: message-id=<20051112195244.580C085FE@server1.domain1.de>
Nov 12 20:52:44 linux postfix/qmgr[1454]: 580C085FE: from=<info@domain2.de>, size=793, nrcpt=1 (queue active)
Nov 12 20:52:44 linux postfix/smtpd[1697]: disconnect from localhost[127.0.0.1]
Nov 12 20:52:44 linux pop3d: Connection, ip=[::ffff:127.0.0.1]
Nov 12 20:52:44 linux pop3d: LOGIN, user=web3_domain21, ip=[::ffff:127.0.0.1]
Nov 12 20:52:44 linux pop3d: LOGOUT, user=web3_domain21, ip=[::ffff:127.0.0.1], top=0, retr=0
Nov 12 20:52:44 linux postfix/smtp[1701]: 580C085FE: to=<mail@domain2.de>, relay=none, delay=0, status=bounced (mail for domain2.de loops back to myself)
Nov 12 20:52:44 linux postfix/cleanup[1700]: 8F10E2A0FE: message-id=<20051112195244.8F10E2A0FE@domain1.de>
Nov 12 20:52:44 linux postfix/qmgr[1454]: 8F10E2A0FE: from=<>, size=2620, nrcpt=1 (queue active)
Nov 12 20:52:44 linux postfix/qmgr[1454]: 580C085FE: removed
Nov 12 20:52:44 linux postfix/smtp[1701]: 8F10E2A0FE: to=<info@domain2.de>, relay=none, delay=0, status=bounced (mail for domain2.de loops back to myself)
Nov 12 20:52:44 linux postfix/qmgr[1454]: 8F10E2A0FE: removed
And I get this error when I send mail from Outlook (Server need authentication is activated!):

Code:
Nov 12 20:55:58 linux postfix/smtpd[1739]: connect from p85.212.28.183.tisdip.tiscali.de[85.212.28.183]
Nov 12 20:56:00 linux postfix/smtpd[1739]: NOQUEUE: reject: RCPT from p85.212.28.183.tisdip.tiscali.de[85.212.28.183]: 554 <mail@domain2.de>: Relay access denied; from=<info@domain2.de> to=<mail@domain2.de> proto=SMTP helo=<PC1>
Nov 12 20:56:00 linux postfix/smtpd[1739]: disconnect from p85.212.28.183.tisdip.tiscali.de[85.212.28.183]

Last edited by yap; 20th December 2005 at 22:01.
Reply With Quote