View Single Post
  #1  
Old 9th March 2007, 19:40
rneilson rneilson is offline
Junior Member
 
Join Date: Mar 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix not honoring email aliases for local delivery

I have a hosting server, configured as per the Perfect Setup (Opensuse 10), with ISPConfig installed. Everything seems to be working - uptime has been over a month, now, with the only problems I've had so far being domain registration hiccups which have nothing to do with my server.

However, one of my customers is testing a web order form, and I've run into a problem: while emails incoming from outside servers work fine, local deliveries don't seem to be using email aliases properly.

Eg.

Username: example.admin
Primary email: example.admin@example.com
Alias: info@example.com

If I send an email to info@example.com from outside, it works without a problem. If I send it from an another domain also hosted on the site, admin@example2.com, it bounces back with the following error:

Quote:
This is the Postfix program at host main.example.com. I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below. For further assistance, please send mail to <postmaster> If you do so, please include this problem report. You can delete your own text from the attached returned message. The Postfix program <info@example.com>: unknown user: "info"
I checked all the threads on Postfix problems I could, and the following have already been ruled out:

- The server's FQDN is main.example.com
- The $myhostname parameter in main.cf is main.example.com
- main.example.com is not used as a virtual domain for any email or web services. www.example.com and example.com are, however.
- All DNS entries are correct. Again, outside email works fine with the alias rewriting.
- alias_maps = hash:/etc/aliases
- virtual_maps = hash:/etc/postfix/virtusertable
- mydestination = /etc/postfix/local-host-names
- example.admin@example.com and info@example.com are both present in /etc/postfix/virtusertable and point to example.admin
- example.com is listed in /etc/postfix/local-host-names

Any help would be greatly appreciated!
Reply With Quote
Sponsored Links