View Single Post
  #1  
Old 7th March 2007, 17:56
agri agri is offline
Junior Member
 
Join Date: Dec 2006
Location: Ingolstadt / Eichstätt
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default No ftp login for ispconfig-webuser

I searched different forums to shed light on my problem - no solution yet, so I have the heart to ask:

I want to connect to a VMware virtual machine via ftp. This does not work:

I use
  • a server with SUSE 10 (no FTP-server on the host!)
  • VMware - only one VM at the moment
  • Network: nat
  • virtual machine: ISPConfig-appliance (Debian)

ISPConfig is running.
I have set up one client and one web with just one user for mail/ftp.
Within ISPConfig FTP is set to "on" for the created web.

What I CAN do:
I can access my VM from 'outside' via http and https using the host IP, i.e.
I can access serverconsole, config-panel, "shared-IP-adress"-page and the user's page at ../~webx_user/.

From the shell of ISPConfig I get ftp at localhost running ok.
Login to config-panel as admin: I can use WebFTP.

What I CANNOT do:
if I try to get FTP-access to my VM with an ftp-client (such as WinFTP) from outside, I get "connection refused" - no access possible.

This seems not to be due to firewall settings, because I get the same, when I switch off the firewalls (host and guest).

I tried to solve it by setting port 8887 in /etc/vmware/vmnet8/nat/nat.conf (8887 = 192.168.77.10:21) and connecting to port 8887 with my ftp-client as well as by activating ports under 1024 in /usr/lib/vmware/configurator/vmnet-nat.conf manually:
> [privilegedTCP]
> autodetect = 1
> port = 21

Negative

Any ideas?

Regards
agri

Last edited by agri; 7th March 2007 at 18:12.
Reply With Quote
Sponsored Links