Thread: apache2 problem
View Single Post
  #3  
Old 6th March 2007, 10:28
laser144 laser144 is offline
Member
 
Join Date: Apr 2006
Posts: 31
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Falko,

The output of ls -la /var/www/sailmaster.nl/:


drwxrwxrwx 16 root root 4096 2007-02-20 10:23 .
drwxr-xr-x 5 root root 4096 2006-12-19 14:21 ..
drwxr-xr-x 9 root root 4096 2006-05-19 21:36 administrator
drwxrwxrwx 2 root root 4096 2006-08-28 21:20 cache
-rwxr-xr-x 1 root root 99938 2006-12-24 21:22 CHANGELOG.php
drwxr-xr-x 24 root root 4096 2006-05-19 21:36 components
-rw-r--r-- 1 www-data www-data 2743 2007-01-16 11:08 configuration.php
-rwxrwxrwx 1 root root 4251 2006-08-28 21:20 configuration.php-dist
-rwxrwxrwx 1 root root 3429 2006-08-28 21:20 COPYRIGHT.php
drwxrwxrwx 2 root root 4096 2006-08-28 21:20 editor
drwxr-xr-x 2 root root 4096 2006-12-21 13:25 files
drwxr-xr-x 8 root root 4096 2006-12-20 08:51 gallery2
-rwxrwxrwx 1 root root 3535 2007-01-22 10:47 globals.php
drwxrwxrwx 3 root root 8192 2007-01-09 09:54 help
-rwxr-xr-x 1 root root 4829 2007-02-20 10:23 .htaccess
-rwxr-xr-x 1 root root 4829 2006-12-24 21:22 htaccess.txt
drwxrwxrwx 8 root root 4096 2007-01-08 10:02 images
drwxrwxrwx 10 root root 4096 2007-01-09 09:54 includes
-rwxr-xr-x 1 root root 5223 2006-12-24 21:22 index2.php
-rwxr-xr-x 1 root root 8491 2006-12-24 21:22 index.php
-rwxr-xr-x 1 root root 4376 2006-12-24 21:22 INSTALL.php
drwxrwxrwx 2 root root 4096 2007-01-09 09:54 language
-rwxrwxrwx 1 root root 17977 2006-08-28 21:20 LICENSE.php
-rwxrwxrwx 1 root root 710 2006-08-28 21:20 mainbody.php
drwxrwxrwx 7 root root 4096 2006-08-28 21:20 mambots
drwxrwxrwx 5 root root 4096 2007-01-21 14:59 media
drwxrwxrwx 6 root root 4096 2007-01-21 14:59 modules
-rwxrwxrwx 1 root root 2474 2006-08-28 21:20 offlinebar.php
-rwxr-xr-x 1 root root 4929 2006-12-24 21:22 offline.php
-rwxrwxrwx 1 root root 709 2006-08-28 21:20 pathway.php
lrwxrwxrwx 1 root root 21 2006-12-19 19:28 phpmyadmin -> /usr/share/phpmyadmin
-rwxrwxrwx 1 root root 286 2006-08-28 21:20 robots.txt
drwxrwxrwx 6 root root 4096 2006-12-19 21:00 templates

From Apache's log:

...snip...

192.168.0.99 - - [05/Mar/2007:16:26:52 +0100] "GET /phpmyadmin/themes/original/img/logo_right.png HTTP/1.1" 304 - "http://192.168.1.2/phpmyadmin/" "Mozilla/5
.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10"
192.168.0.99 - - [05/Mar/2007:16:33:54 +0100] "GET /administrator/ HTTP/1.1" 200 2116 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20
070216 Firefox/1.5.0.10"
192.168.0.99 - - [05/Mar/2007:16:34:01 +0100] "GET / HTTP/1.1" 302 380 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/
1.5.0.10"
192.168.0.99 - - [05/Mar/2007:16:34:01 +0100] "GET /apache2-default/ HTTP/1.1" 404 1173 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/
20070216 Firefox/1.5.0.10"
192.168.0.99 - - [05/Mar/2007:17:06:59 +0100] "GET /administrator/ HTTP/1.1" 200 2116 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20
070216 Firefox/1.5.0.10"
192.168.0.99 - - [05/Mar/2007:17:07:02 +0100] "GET / HTTP/1.1" 302 380 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/
1.5.0.10"
192.168.0.99 - - [05/Mar/2007:17:07:02 +0100] "GET /apache2-default/ HTTP/1.1" 404 1173 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/
20070216 Firefox/1.5.0.10"
192.168.0.99 - - [05/Mar/2007:17:07:04 +0100] "GET /phpmyadmin/ HTTP/1.1" 200 12074 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/2007
0216 Firefox/1.5.0.10"
192.168.0.99 - - [05/Mar/2007:17:07:04 +0100] "GET /phpmyadmin/css/phpmyadmin.css.php?lang=nl&js_frame=right&js_isDOM =1 HTTP/1.1" 200 12240 "http://192.168.1
.2/phpmyadmin/" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10"
192.168.0.1 - - [05/Mar/2007:18:41:19 +0100] "GET / HTTP/1.1" 302 384 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/1
.5.0.10"
192.168.0.1 - - [05/Mar/2007:18:41:19 +0100] "GET /apache2-default/ HTTP/1.1" 404 1175 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/2
0070216 Firefox/1.5.0.10"
192.168.0.1 - - [05/Mar/2007:18:41:19 +0100] "GET /favicon.ico HTTP/1.1" 404 1175 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/200702
16 Firefox/1.5.0.10"
84.16.231.53 - - [05/Mar/2007:22:34:40 +0100] "" 414 429 "-" "-"
84.16.231.53 - - [06/Mar/2007:04:49:17 +0100] "" 414 429 "-" "-"
192.168.0.99 - - [06/Mar/2007:09:23:36 +0100] "GET /administrator/ HTTP/1.1" 200 2116 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20
070216 Firefox/1.5.0.10"
192.168.0.99 - - [06/Mar/2007:09:23:37 +0100] "GET / HTTP/1.1" 302 380 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/
1.5.0.10"
192.168.0.99 - - [06/Mar/2007:09:23:37 +0100] "GET /apache2-default/ HTTP/1.1" 404 1173 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/
20070216 Firefox/1.5.0.10"
192.168.0.99 - - [06/Mar/2007:09:42:37 +0100] "GET /administrator/ HTTP/1.1" 200 2116 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20
070216 Firefox/1.5.0.10"
192.168.0.99 - - [06/Mar/2007:09:42:39 +0100] "GET / HTTP/1.1" 302 380 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/20070216 Firefox/
1.5.0.10"
192.168.0.99 - - [06/Mar/2007:09:42:39 +0100] "GET /apache2-default/ HTTP/1.1" 404 1173 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.0.10) Gecko/
20070216 Firefox/1.5.0.10"

/...snip...

BTW: I just got this back from http://www.dnsreport.com/tools/dnsre...=sailmaster.nl

...snip...
WARN TCP Allowed WARNING: One or more of your DNS servers does not
accept TCP connections. Although rarely used, TCP connections are
occasionally used instead of UDP connections. When firewalls block the
TCP DNS connections, it can cause hard-to-diagnose problems. The problem
servers are:

212.79.232.3: Timeout. 195.245.199.130: Timeout. 212.79.243.3: Timeout.
WARN Single Point of Failure WARNING: Although you have at least 2 NS
records, there is a chance that they may both point to the same server
(one of our two tests shows them being different, the other is unsure;
it appears that there are one or more firewall(s) that intercept and
alter DNS packets (some versions of Linux reportedly have a built-in
firewall that does this, too)), which would result in a single point of
failure. You are required to have at least 2 nameservers per RFC 1035
section 2.2.
/...snip...

Could that be part of the problem?

Regards,

Andy

Last edited by laser144; 6th March 2007 at 13:23.
Reply With Quote