Thread: PostgreSQL
View Single Post
  #2  
Old 5th August 2005, 08:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,688
Thanks: 819
Thanked 5,318 Times in 4,171 Posts
Default

Quote:
Originally Posted by boardmain
i'have created the update package for install
phppgadmin

but when i try to launch it i have the errore message becouse
php isn't copiled with --with-pgsql
this error if related to apache of ispconfig webserver or system apache?

how i can solve it?

(the request is for a official postgresql release :P )
This is related to the PHP / apache of ISPConfig.

To compile the ISPConfig PHP with postgres:

1) Download the ISPConfig installer tar.gz and unpack it.
2) cd istall_ispconfig/compile_aps
3) Edit the script "compile" in the compile_aps folder and add the
--with-pgsql directive in the PHP configure statement (line 85)
4) Stop ISPConfig: /etc/init.d/ispconfig_server stop
5) Run the compile script ( ./compile)
4) Start ISPConfig: /etc/init.d/ispconfig_server start

Remark: This is untested

May you send the phppgadmin package to dev [at] ispconfig [dot] org
when everything is working? Then we can put it on the downloads page.
Reply With Quote