View Single Post
  #5  
Old 2nd March 2007, 17:43
wonka wonka is offline
Junior Member
 
Join Date: Feb 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ive tested alias, rewrites and redirects. My current config is ISPServer 2.2.10, Apache 2.0.52, and Roundcube webmail (I know it is still beta but I'd like to use something different than squirrelmail).

Everything works fine and the issue is just making invisible the server URL when loading the webmail from other created domain.

Server running ISPConfig: www.server.com
Domain created from ISPConfig: www.domain.tld

So among other things Ive tested this at the domain.tld section on Vhosts_ispconfig.conf:

Test 1:
-------
Alias /webmail "/home/admispconfig/ispconfig/web/webmail"

Result 1:
--------
Roundcube page loads with no login fields and an error that says "SERVICE CURRENTLY NOT AVAILABLE Error No. 1f4)"
Also /var/www/web4/log/error.log (which is the log file for www.domain.tld) shows "PHP Notice: DB Error: extension not found in /home/admispconfig/ispconfig/web/webmail/program/include/bugs.inc on line 80".
But if I load www.domain.tld:81/webmail Roundcube loads fine.

Test 2:
-------
Redirect /webmail http://www.domain.tld:81/webmail

Test 3:
-------
RewriteEngine on
RewriteRule ^/webmail http://%{SERVER_NAME}:81/webmail

Test 4:
-------
RewriteEngine on
RewriteRule ^/webmail http://www.domain.tld:81/webmail


Results 2, 3, 4:
---------------
Loads www.server.com:81/webmail
(Remember that the expected result should be that the browser shows as URL www.domain.tld:81/webmail)


Please advise what can I test. Thanks,

Edo
Reply With Quote