View Single Post
  #9  
Old 10th November 2005, 18:04
senzapaura senzapaura is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I hope you have not given up on me. It is a mater of survival for me. I am continuing to pursue this problem and maybe in the process can gain some insight on how apache and ISPConfig work. Would you mind reviewing this information and letting me know your thoughts.

It looks (to me) that ISPConfig changes this file (Vhosts_ispconfig.conf) and then restarts apache automatically, if you change something within the forms. Problem is nothing seems to do this in a consistent manner. On one occasion when I turned safe_mode off (manually), it actually worked. Well almost, the write to /home/web1/uploads did not work, but I think that was because I had forgotten to set the open_base_dir value correctly. unfortunately when I did this it stopped working again. On another occasion when I changed the safe_mode setting on a form, the php settings were cleared from this file (Vhosts_ispconfig.conf). One thing (of many) I do not understand is why does turning safe_mode on or off affect apache from displaying a screen. When it is not working apache sends back an html file with an empty head and body area. I cannot even find a template like this on the system.

I know people always blame a new piece of software for any problem they are having when in reality it is operator error. I am resisting this urge, but I cannot help but wonder from the erratic behavior I have experienced from making some simple straight forward one line changes to this file that possibly apache2 has a problem? It also appears that if you make a change to the php.ini file like changing the open_base_dir value as you indicated previously and restart, ISPConfig will change it the first time in this file (Vhosts_ispconfig.conf), but ignores any subsequent changes, which is probably correct since once this virtual hostís settings are made they should not be changed globally, because they could be different for each virtual host. But that means the only way to change it (in this example open_base_dir) would be manually, since I do not see any form field for this setting this value.

In addition if you would review the warning messages (at the end of this message) I get when restarting apache, maybe this will provide a hint to where I made my mistake.

###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.3.170:80
#
#
######################################
# Vhost: www.amg01.info:80
######################################
#
#
<VirtualHost 192.168.3.170:80>
ServerName www.amg01.info:80
ServerAdmin webmaster@amg01.info
DocumentRoot /var/www/web1/web
ServerAlias www.amg01.info
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi ind
ex.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
php_admin_value open_base_dir /home/web1/uploads/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /var/www/web1/phptmp/
php_admin_value session.save_path /var/www/web1/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#

Another hint may come from these messages I get when restarting apache:

amgsrv1:/etc/apache2/vhosts # /etc/init.d/apache2 restart
[Thu Nov 10 09:27:43 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
[Thu Nov 10 09:27:43 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
Syntax OK
Shutting down httpd2 (waiting for all children to terminate) done
Starting httpd2 (prefork) [Thu Nov 10 09:27:45 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
[Thu Nov 10 09:27:45 2005] [warn] NameVirtualHost 192.168.3.170:80 has no VirtualHosts
done
amgsrv1:/etc/apache2/vhosts #
Reply With Quote