View Single Post
  #5  
Old 27th February 2007, 00:31
brug71 brug71 is offline
Junior Member
 
Join Date: Feb 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sgla1
Hi falko and thanks for your reply.

I have looked at the tutorial you mentioned; in fact I have used it in slightly modified form to set up two different mandrake samba servers. the command cupsaddsmb works on them--it copies the drivers to /var/lib/samba/printers/W32X86 without error.

The problem only happens on my ubuntu dapper system, which I wanted to use as a print server because it has the printer installed locally.

As an experiment, in /var/lib/samba/printers I did
Code:
mv W32X86/ W32X86.old
I now get a slightly different error:
Code:
Unable to copy Windows 2000 printer driver files (1)!
Running command: smbclient ///var/run/cups/cups.sock/print$ -N -A /var/spool/cups/tmp/44d10de0386ba -c 'mkdir W32X86;put /var/spool/cups/tmp/44d10dd62f210 W32X86/HPofficejet.ppd;put /usr/share/cups/drivers/ps5ui.dll W32X86/ps5ui.dll;put /usr/share/cups/drivers/pscript.hlp W32X86/pscript.hlp;put /usr/share/cups/drivers/pscript.ntf W32X86/pscript.ntf;put /usr/share/cups/drivers/pscript5.dll W32X86/pscript5.dll'
Connection to  failed
What do you suppose "Connection to failed" means? Whatever, it seems to be an ubuntu dapper thing. I have checked the logs; they show nothing useful. Also, cupsaddsmb will not create the dir W32X86.

Steve
Hi Steve, I don't know if my reply style is correct. I rarely write online so be patient.
I had the same problem using Ubuntu 6.10 & Samba 3.0.22 (cups, foomatic and so on...). I solved it temporarily switching security from "share" to "user" and after cupsaddsmb switched back. I've got the same behaviour you get, If you need some more information ask. Now I solved my problem and is time to go. I hope this will help. Regards to everybody.
Reply With Quote