View Single Post
  #9  
Old 23rd February 2007, 11:32
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Feb 23 01:11:39 localhost amavis[1757]: (01757-01) connect_to_sql: unable to connect to DSN 'DBI:mysql:database=mail;host=12$
I see the above in your log file. That indicates either a problem with the package, but on second look it might also be because you missed a configuration step. Previous post:
Quote:
I ask this because:
Now we have to edit /etc/amavis/amavisd.conf. This is a very long file with lots of comments. I have stripped out the unnecessary parts, this is with what I ended up (make sure you adjust line 112 (@lookup_sql_dsn = ( ['DBI:mysql:database=mail;host=127.0.0.1;port=3306' , 'mail_admin', 'mail_admin_password'] ); to your own database settings):

And I didn't alter anything.
The host should be something like localhost and not something with 12 as indicated from you log file. Could you check your /etc/amavis/amavisd.conf?
Reply With Quote