View Single Post
  #1  
Old 21st February 2007, 22:21
FredZ FredZ is offline
Member
 
Join Date: Oct 2006
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs

Hello

Well after setting up my postfix server, I am now testing it prior to installing a web client.

Under FC6 I am using Evolution to connect to the mail server.

If I setup the mail client to use POP I get no error, however, if I setup the client to use IMAP it will not authenticate (keeps asking for the password)

The mail.log states:

localhost authdaemond.mysql: failed to connect to mysql server (server=localhost, userid=mail_admin)
Localhost imapd-ssl: LOGIN FAILED, ip=[::ffff:192.168.1.199]

I am assuming the mysql server cannot be contacted. I have no idea on how to rectify this problem. Mysql server is running, and starts without errors.

Something else has just dawned upon meafter reading the document again.
Every where I find an instance of:
mail_admin
mail_admin_password
Should these be changed?
I ask this because:
Now we have to edit /etc/amavis/amavisd.conf. This is a very long file with lots of comments. I have stripped out the unnecessary parts, this is with what I ended up (make sure you adjust line 112 (@lookup_sql_dsn = ( ['DBI:mysql:database=mail;host=127.0.0.1;port=3306' , 'mail_admin', 'mail_admin_password'] ); to your own database settings):

And I didn't alter anything.

I am starting to think I haven't set the mail_admin and mail_admin_password at all and it has nothing to auth against.

Comments please

Regards

Fred

Last edited by FredZ; 21st February 2007 at 23:59.
Reply With Quote
Sponsored Links