View Single Post
  #3  
Old 19th February 2007, 23:27
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi, thanks for replying!
Quote:
Originally Posted by martinfst
The installation procedure of ISPConfig modifies the PHP settings for Apache(2). It removes the standard allowed php execution. Otherwise you could not select to switch php on or off for a website. If you want to run PHP, you have to set the PHP tick box for every website you want php to work on.
Yes, while I don't know the actual process I was aware it did this. I have been through the setup twice with PHP checked for the applicable sites. There was even remedy in the previous thread I linked that indicates not to check the boxes therefore preventing ISPConfig from altering PHP configurations but that did not work either.
Quote:
Originally Posted by martinfst
Maybe you created a website yourself in the main apache2.conf? If that's true, you should leave the creation of sites and apache configurations to ISPconfig. Just thinking out loud.
Probably not, I did not mess with the apache configs except where directed by the Perfect Setup for opensuse10.2. I did set up the sites via ISPConfig on the previous tries but again when I access the sites from the internet I could not access any PHP pages or content. On my last install of opensuse10.2 without installing ISPConfig I still didn't mess with the apache config files. I simply copied all the files for a site directly into /srv/www/htdocs and as I said when I tried to access PHP content it worked with no problem.

With ISPConfig installed, sites up, this is the appache2 error I receive when I tried to access PHP content
Code:
[Sun Feb 18 17:52:29 2007] [error] [client ::1] Directory index forbidden by Options directive: /srv/www/htdocs/
which is why I am thinking maybe ISPConfig should be setting the sites up in /srv/www/htdocs/ instead of /srv/www/. I am willing to give it a try but I do not know where/what to change in ISPConfig to do this.
Reply With Quote