View Single Post
  #2  
Old 11th February 2007, 23:27
cio cio is offline
Junior Member
 
Join Date: Feb 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just found it at the 10th page after googling

I am posting the solution in case some one has the same problem:

in your source folder's root edit the Makefile like this:

in the original makefile cflags assignment was like this:
CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
-fno-strict-aliasing -fno-common

add this option:
CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
-fno-strict-aliasing -fno-common -fno-stack-protector

the other may change from different kernel versions, the only thing is to add -fno-stack-protector.

and also add this at the end of assignments to cflags here:

initially:

CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)

CFLAGS += $(call cc-option,-Wno-pointer-sign,)

after modifying with this line:

CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)

CFLAGS += $(call cc-option,-Wno-pointer-sign,)

CFLAGS += $(call cc-option, -fno-stack-protector-all \
-fno-stack-protector)

this forum was a lucky charm for me I hope I can help!
Reply With Quote