View Single Post
  #14  
Old 10th February 2007, 20:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by sremac
On Internet are lot of explanation, but still problems

http://www.postfix.org/SMTPD_ACCESS_README.html

This option is making problems to me:

smtpd_client_restrictions = permit_mynetworks, reject

when I turn it on in main.cf, server responds:

mail from:<igor@virtual.test>
250 2.1.0 Ok
rcpt to:<igor@virtual.test>
451 4.3.5 Server configuration error


when trying to aproach from different network.

So, what options need to be turned in main.cf in order to:

1. check mynetworks and allow everything from that
2. if mynetworks don`t pass then to use smtp auth

?
It's all in the tutorial ( http://www.howtoforge.com/virtual_po...ota_courier_p2 ). Please run
Code:
postconf -e 'smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination'
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote