View Single Post
  #3  
Old 4th February 2007, 13:16
thim thim is offline
Member
 
Join Date: Jun 2006
Location: Belgium
Posts: 34
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi Falko,

We used the postfix source package from http://postfix-mudd.nobandwidth.net/...able-packages/ to compile postfix.

We configured and compiled postfix in '/usr/src/redhat/SOURCES'
When I was looking at the 'postfix.spec' file I saw that this version of Postfix was copying the 'smtpd.conf' file in '/usr/lib/sasl2/smtpd.conf'. So after installing , I modified this file with our configuration:
Code:
pwcheck_method: authdaemond
log_level: 3
mech_list: PLAIN LOGIN
authdaemond_path:/usr/var/spool/authdaemon/socket
This is the complete error message:
Code:
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: connect from unknown[81.165.135.66]
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: warning: SASL authentication failure: realm changed: authentication aborted
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: warning: unknown[81.165.135.66]: SASL DIGEST-MD5 authentication failed: authentication failure
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: warning: unknown[81.165.135.66]: SASL LOGIN authentication failed: authentication failure
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: lost connection after AUTH from unknown[81.165.135.66]
Feb  3 22:35:46 gonzo postfix/smtpd[4321]: disconnect from unknown[81.165.135.66]
We compiled postfix with:
Code:
CCARGS=' -DHAS_LDAP -DHAS_PCRE -I/usr/include/pcre -DHAS_MYSQL -I/usr/include/mysql -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl -I/usr/kerberos/include -DUSE_TLS -I/usr/include/openssl'
AUXLIBS=' -L/usr/lib -lldap -llber -lpcre -L/usr/lib64/mysql -lmysqlclient -lm -L/usr/lib/sasl2 -lsasl2 -lssl -lcrypto -lz'
We are running CentOS 4.4 64bit.
We installed this software / libraries:
Code:
postfix.x86_64                           2:2.3.6-1.pcre.mysql_p installed
courier-authlib.x86_64                   0.58-1                 installed
courier-authlib-devel.x86_64             0.58-1                 installed
courier-authlib-mysql.x86_64             0.58-1                 installed
courier-imap.x86_64                      4.1.1-1                installed
cyrus-sasl.x86_64                        2.1.19-5.EL4           installed
cyrus-sasl.i386                          2.1.19-5.EL4           installed
cyrus-sasl-devel.x86_64                  2.1.19-5.EL4           installed
cyrus-sasl-md5.x86_64                    2.1.19-5.EL4           installed
cyrus-sasl-plain.i386                    2.1.19-5.EL4           installed
cyrus-sasl-plain.x86_64                  2.1.19-5.EL4           installed
cyrus-sasl-sql.i386                      2.1.19-5.EL4           installed
cyrus-sasl-sql.x86_64                    2.1.19-5.EL4           installed
Hope you can help to solve this, because this is an hard one to solve..

Thanks in advance!
Reply With Quote