View Single Post
  #26  
Old 24th January 2007, 23:20
gabrix gabrix is offline
Senior Member
 
Join Date: Sep 2006
Location: Napoli
Posts: 186
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via MSN to gabrix Send a message via Yahoo to gabrix Send a message via Skype™ to gabrix
Default

Realying mail to gmail requires mandatorly the use of saal2-bin package right ?So i have set my postfix accordingly to some tutorials i have foung here but now my password get rejected these are my settings:
Code:
root@mail:~# postconf -n
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_list = 192.168.1.0/24 ,192.168.0.0/24
delay_warning_time = 4h
disable_dns_lookups = yes
home_mailbox = Maildir/
inet_interfaces = all
mailbox_size_limit = 0
message_size_limit = 0
mydestination = $mydomain, mail.gabrix.ath.cx, www.gabrix.ath.cx, localhost.gabrix.ath.cx, , argo.gabrix.ath.cx, argo,localhost
mydomain = gabrix.ath.cx
myhostname = mail.gabrix.ath.cx
mynetworks = 192.168.1.0/24,192.168.0.0/24,127.0.0.0/8
myorigin = /etc/mailname
recipient_delimiter = +
relayhost = gmail-smtp.l.google.com
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,reject_unauth_destination, permit
smtpd_reject_unlisted_recipient = no
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options =
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/cert.pem
smtpd_tls_key_file = /etc/postfix/ssl/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
The file /etc/postfix/sasl/sasl_passwd only contains this:
Code:
gmail-smtp.l.google.com       sickuser@gmail.com:dhghghjf
I have CP hosts localtime nsswitch.conf resolv.conf services to /var/spool/postfix/etc shall i CP also passwd to that dir ?How do i say to postfix of new passwd location ?
and in logs i get this:
Code:
Jan 24 22:55:22 mail postfix/smtpd[24109]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
And finally the connection result with smtp.gmail.com
Code:
Jan 25 00:55:53 mail postfix/smtp[25301]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 00:55:53 mail postfix/smtp[25301]: setting up TLS connection to gmail-smtp.l.google.com
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=20:unable to get local issuer certificate
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=20:unable to get local issuer certificate
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=27:certificate not trusted
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=27:certificate not trusted
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=21:unable to verify the first certificate
Jan 25 00:55:56 mail postfix/smtp[25301]: verify error:num=21:unable to verify the first certificate
Jan 25 00:55:59 mail postfix/smtp[25301]: Peer certificate could not be verified
Jan 25 00:55:59 mail postfix/smtp[25301]: Peer certificate could not be verified
Jan 25 00:56:09 mail postfix/qmgr[24799]: 826FF1BFB9: removed
Jan 25 00:56:09 mail postfix/qmgr[24799]: 826FF1BFB9: removed
This is a log update
Code:
Jan 25 04:02:54 mail postfix/smtp[4527]: warning: SASL authentication failure: No worthy mechs found
Jan 25 04:02:54 mail postfix/smtp[4527]: warning: SASL authentication failure: No worthy mechs found
Jan 25 04:02:54 mail postfix/smtp[4527]: 0B7A71BFB7: to=<gabrix@gabrix.ath.cx>, relay=gmail-smtp.l.google.com[72.14.205.109], delay=27, status=deferred (Authentication failed: cannot SASL authenticate to server gmail-smtp.l.google.com[72.14.205.109]: no mechanism available)
That's where i got smtp.gmail.com connection details and instructions to set a relayhost on postfix with gmail:
http://groups.google.com/group/alt.c...03d95?lnk=raot
__________________
http://www.gabrix.ath.cx

Last edited by gabrix; 25th January 2007 at 07:42.
Reply With Quote