View Single Post
  #10  
Old 11th January 2007, 01:13
richjam000 richjam000 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've had some success using http proxy stuff.

ie: say this is my URL for ispconfig: https://www.fred.com:81
I then setup a new SSL vhost ( https://www.bill.com) containing this:
SSLProxyEngine On
ProxyPreserveHost On
ProxyPass /ispconfig https://www.fred.com:81/
ProxyPassReverse /ispconfig https://www.fred.com:81/
ProxyPass /design https://www.fred.com:81/design/
ProxyPassReverse /design https://www.fred.com:81/design/
ProxyPass /squirrelmail https://www.fred.com:81/squirrelmail/
ProxyPassReverse /squirrelmail https://www.fred.com:81/squirrelmail/

Not really sure what Im doing ! - just copying something I did when setting
up ntop.

With the above set-up ispconfig seems to work just fine - ie: over port 80,
proxied to port 81. - via https://www.bill.com/ispconfig/

However the squirrelmail doesnt quite work - once I've logged in to
squirrelmail ( via https://www.bill.com/squirrelmail. ), I see my mail OK but
the URL , annoyingly , changes to :
https://www.bill.net:81/squirrelmail//src/webmail.php
ie: seems to go back to port 81.

Bit stuck now - maybe someone can take this forward ?
Reply With Quote