View Single Post
  #1  
Old 2nd November 2005, 11:42
Genghis Genghis is offline
Junior Member
 
Join Date: Nov 2005
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS allow-transfer for secundary NS

Hi,

I'm trying to add a new domain to my dedicated box using ispconfig.
I'm using that box as the primary nameserver, and I would like to use a secondary nameserver at some free dns hoster.
Now, the problem is, that I need a "allow-transfer" part in my /etc/bind/named.conf , but it seems there is no option @ ispconfig like that...

I tried commenting out the original zone in named.conf (generated by ispconfig) and add a new zone in the "//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////" zone, having allow-transfer as an option for that domain.
It works fine untill I edit or make a new entry for that domain using ispconfig, since ispconfig is generating a new zone for that domein, and is reloading Bind, wich wont startup due to duplicate zone in named.conf.

Here are my configs:

//ORIGINAL CREATED BY ISPCONFIG named.conf

zone "example.com" {
type master;
file "pri.example.com";
};

// I deleted the above and made a new entry manually:

//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////

zone "example.com" {
type master;
file "pri.example.com";
allow-transfer {
192.168.0.1;
};
};

That works fine, untill I make a change to the domain using ISPCONFIG.

Anyone had the same prob and found a solution?

Thanks in advance,
Genghis
Reply With Quote
Sponsored Links