View Single Post
  #4  
Old 9th January 2007, 19:33
justix justix is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

Yes there is an error saying that I can't connect to autoreply.testdomain.com
I specified autoreply.testdomain.com in the postfixadmin config file.
My var/log/maillog shows as follows:

Code:
Jan  8 16:05:55 mail6 postfix/smtp[25727]: connect to autoreply.testdomain.com[10.0.0.1]: Connection refused (port 25)
Jan  8 16:05:56 mail6 postfix/smtp[25727]: BB91C38300A2: to=<justin@realdomain.com@autoreply.testdomain.com>, relay=none, delay=1, status=deferred (connect to autoreply.testdomain.com[10.0.0.1]: Connection refused)
Jan  8 16:05:56 mail6 postfix/smtp[25727]: BB91C38300A2: to=<justin@realdomain.com@autoreply.testdomain.com>, orig_to=<croft@realdomain.com>, relay=none, delay=1, status=deferred (connect to autoreply.testdomain.com[10.0.0.1]: Connection refused)
Jan  8 16:05:56 mail6 postfix/smtp[25727]: BB91C38300A2: to=<justin@realdomain.com@autoreply.testdomain.com>, orig_to=<justin@realdomain.com>, relay=none, delay=1, status=deferred (connect to autoreply.testdomain.com[10.0.0.1]: Connection refused)
Jan  8 16:07:10 mail6 postfix/pipe[25550]: 7B80538300A7: to=<justin@realdomain.com@autoreply.testdomain.com>, orig_to=<croft@realdomain.com>, relay=spamassassin, delay=5, status=sent (mail6.testdomain.com)
Jan  8 16:07:10 mail6 postfix/smtp[25727]: connect to autoreply.testdomain.com[10.0.0.1]: Connection refused (port 25)

But If I try to modify my master.cf like this:


Code:
smtp      inet  n       -       n       -       -       smtpd
#	-o content_filter=spamassassin
	-o content_filter=vacation:dummy

Code:
#SpamAssassin
spamassassin unix -	n	n	-	-	pipe
	user=nobody argv=/usr/bin/spamc -f -e
	/usr/sbin/sendmail.postfix -oi -f ${sender} ${recipient}
#Vacation / Autoreply
vacation  unix   -   n   n   -   -   pipe
    flags=Rq user=vacation argv=/var/spool/vacation/vacation32.pl -f ${sender} -- ${recipient}
#  flags=DRhu user=vacation:vacation argv=/usr/bin/perl argv=/var/spool/vacation/vacation.pl

Basically, I commented out spamassassin content_filter and put vacation:dummy then vacation works partially. It sends out the autoreply message to the sender but only once. If the same sender tries to send another email then the mail disappears. It does not get delivered to the destined mailbox. And when I put spamassassin and vacation in content_filter at the same time, both of them do not work. I just don't know how to put it together. Is there any way to keep spamassassin in the content_filter (since it is working) and just add another filter that sends out autoreply messages?


Thank you for your time and help.
I really appreciate.
Reply With Quote