View Single Post
  #7  
Old 9th January 2007, 03:46
wiremeister wiremeister is offline
Junior Member
 
Join Date: Sep 2006
Posts: 23
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi Falko,

A Dig at ns3 or ns4 do not bring any results at all. Digging at the IP's bring up all the appropriate records. Perhaps things are just being slow propagating. I don't know. Checking NS3 and NS4 at Internic and Verisign show they are registered name servers. Just no results, and testing DNS at DNSStuff.com again this evening still shows the disconnect at our servers.

Here's Named.conf:

options {
pid-file "/var/lib/named/var/run/named.pid";
directory "/var/lib/named/var/named";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "named.local";
};

zone "214.92.74.in-addr.arpa" {
type master;
file "pri.214.92.74.in-addr.arpa";
};

zone "sheltiehosting.net" {
type master;
file "pri.sheltiehosting.net";
};

zone "sheltiehosting.com" {
type master;
file "pri.sheltiehosting.com";
};

zone "sheltiehosting.org" {
type master;
file "pri.sheltiehosting.org";
};


//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////


Here's also named.conf.master from ISPConfig:

options {
pid-file "/var/lib/named/var/run/named.pid";
directory "{BINDDIR}";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "named.local";
};

<!-- BEGIN DYNAMIC BLOCK: named_reverse -->
zone "{ZONE}.in-addr.arpa" {
type master;
file "pri.{ZONE}.in-addr.arpa";
};
<!-- END DYNAMIC BLOCK: named_reverse -->

<!-- BEGIN DYNAMIC BLOCK: named -->
zone "{DOMAIN}" {
type master;
file "pri.{DOMAIN}";
};
<!-- END DYNAMIC BLOCK: named -->

<!-- BEGIN DYNAMIC BLOCK: named_slave -->
zone "{DOMAIN}" {
type slave;
file "sec.{DOMAIN}";
masters { {MASTERS}; };
};
<!-- END DYNAMIC BLOCK: named_slave -->

//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////

The only change I made to named.conf was to uncomment the query source port address. Otherwise, setup was done with the Perfect Setup for Mandriva 2007. No Firewall on the system other than the firewall within ISPConfig. Straight shot to the net.

Last edited by wiremeister; 9th January 2007 at 03:49.
Reply With Quote