View Single Post
  #1  
Old 26th December 2006, 01:06
marsvin marsvin is offline
Junior Member
 
Join Date: Dec 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default PureFTPd and MySQL: error exit status 252

Hi All,

I'm having some trouble getting pureftpd to run as advertised in Virtual Hosting With PureFTPd And MySQL

I installed pure and mysql with aptitude but when I try to run it it exits with error 252:

Code:
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -j -O clf:/var/log/pure-ftpd/transfer.log -u 1000 -A -E -B
invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
dpkg: error processing pure-ftpd-mysql (--configure):
 subprocess post-installation script returned error exit status 252
I found another post by someone with the same problem (post) and checked all the settings mentioned there, everything seems fine. The MySQL user is present and I'm able to log in and alter the db under its credentials. MySQL is running and the socket file is present (I tried connecting through tcp as well, same result.)

MySQL logs don't show anything at all outside my own creation of the test-user and the pureftpd log doesn't even seem to have been generated yet.

Oh it may be important to note, during the aptitude install process I was asked one question not mentioned in the howto, do I want to chroot all users? I answered yes. If I remove the package and reinstall it now, the question doesn't come up any more so I'm not sure how to undo that if it is the problem.

Any more thoughts anyone?
Reply With Quote
Sponsored Links