View Single Post
  #4  
Old 12th December 2006, 04:06
PrawnStar PrawnStar is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via ICQ to PrawnStar Send a message via AIM to PrawnStar Send a message via Yahoo to PrawnStar
Default

Quote:
Originally Posted by n74jw
My first issue started on step 10, when I was running the command.

chown -R bind:bind /var/lib/named/var/*

The directory did not exist. I changed the second var before the /* to dev and the command completed properly.

The issue became more apparent when I restarted Bind and checked the syslog and found numerous errors, basically indicated Bind did not start.

excerpt...............................

Nov 6 16:15:13 barf named[3719]: found 1 CPU, using 1 worker thread
Nov 6 16:15:13 barf named[3719]: loading configuration from '/etc/bind/named.conf'
Nov 6 16:15:14 barf named[3719]: /etc/bind/named.conf.options:2: change directory to '/var/cache/bind' failed: file not found
Nov 6 16:15:14 barf named[3719]: /etc/bind/named.conf.options:2: parsing failed
Nov 6 16:15:14 barf named[3719]: loading configuration: file not found
Nov 6 16:15:14 barf named[3719]: exiting (due to fatal error)
...........................................

/N
I also got the first problem and found it was due to the pid file being stored inside the chroot...

If you are having this problem then try setting dirs/files up like this:

drwxr-xr-x 2 bind bind 4096 Dec 12 01:56 /var/lib/named/var/run/bind/run/
root@mail:/etc/bind# ls -l /var/lib/named/var/run/bind/run/
total 4
-rw-r--r-- 1 bind bind 6 Dec 12 01:56 named.pid

It worked for me, and now I'm going to bed

p.s. not sure about the mysql problem
Reply With Quote