View Single Post
  #1  
Old 10th December 2006, 20:43
meridianblade meridianblade is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default fastCGI and PHP just wont work!

Hey guys, I am absolutely stressed out with this, I just cant figure it out. Im trying to get fastCGI to work on Apache/1.3.37 with php-4.4.3.

I need to run phpsuexec and eaccelerator together and for that I need to get fastCGI working on my box.

Here's what I have done so far:

I downloaded and compiled fastCGI.

Ran the following commands:
Code:
/usr/local/apache/bin/apxs -o mod_fastcgi.so -c *.c
/usr/local/apache/bin/apxs -i -a -n fastcgi mod_fastcgi.so
so my server returns and shows that fastCGI is loading:
Server Version: Apache/1.3.37 (Unix) mod_fastcgi/2.4.2 mod_gzip/1.3.26.1a mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 mod_ssl/2.8.28 OpenSSL/0.9.7a PHP-CGI/0.1b

I added the following to the bottom of my httpd.conf
Code:
<IfModule mod_fastcgi.c>
    FastCgiIpcDir /tmp/fcgi_ipc/
    AddHandler fastcgi-script .fcgi
    FastCgiSuExec /usr/local/apache/bin/suexec
</IfModule>
FastCgiConfig -maxClassProcesses 20 -maxProcesses 20 -minProcesses 1 -processSlack 1 -idle-timeout 120
then:
Code:
mkdir -p /tmp/fcgi_ipc
chmod 755 /tmp/fcgi_ipc -R
then I compiled PHP-4.4.3 with the following:
Code:
./configure --prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib --enable-force-cgi-redirect -–enable-fastcgi

make 
make install
finally a service httpd restart

needless to say my server api still shows CGI and a php -v doesnt display fastCGI at all.

What am I missing guys? :-(

Thanks for your help in advance!
Reply With Quote
Sponsored Links