View Single Post
  #1  
Old 23rd October 2005, 03:40
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,269
Thanks: 84
Thanked 25 Times in 21 Posts
Default cannot chown (change owner of folder) ?

###edit###
I just noticed a typo in the post title: it should say: chown instead of chmod

I did a ls -al inside my /var/www and this is part of the result:

Quote:
drwxr-xr-x 9 web12_postmaster web12 4096 2005-10-17 02:33 web12
drwxr-xr-x 9 spamd web14 4096 2005-10-23 02:27 web14
drwxr-xr-x 10 web6_postmaster web6 4096 2005-10-20 00:53 web6
drwxr-xr-x 12 web7_test web7 4096 2005-10-22 11:05 web7
I tried a
Quote:
chown -R web14_postmaster:web14 web14/
which is the default settign as it should be. The comand is executed but there is no change. Still the same settings like above. I am logged in as a user and then did a sudo su to get root powers...

can anyone suggest how to get rid of this problem?

btw. spamd is a user I made for a local version of spamassassin running for another task, but I am sure I never gave that user rights to this folder...

###edit###
I found a log entry that seems connected to this:

Quote:
Oct 23 10:12:23 h5810 postfix/local[3912]: warning: maildir access problem for UID/GID=10026/10014: create /var/www/web14/user/web14_a1/Maildir/tmp/1130055143.P3912.hxxxx.serverkompetenz.net: Permission denied
very strange - one of the accounts below the falsely spamd-owned folder can access mail (he is the admin of the site) but another user here you can see web14_a1 cannot...
Any ideas? I'd like to solve this in an elegant matter not just by deleting the domain from ispconfig and from cache and then recreating...

Last edited by Ovidiu; 23rd October 2005 at 12:09.
Reply With Quote
Sponsored Links