View Single Post
Old 6th November 2006, 23:39
n74jw n74jw is offline
Junior Member
Join Date: Oct 2006
Location: Philly, PA USA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to n74jw
Question The Perfect Setup - Ubuntu 6.10 Server Question


I am trying out "The Perfect Setup" for Ubuntu 6.10 server. I am not using the official server-version of Ubuntu but the standard Edgy desktop. All things have been going well thus far. I am not a complete Ubuntu novice, but Bind is something I have never been able to get to work properly. Apparently Bind is biting me in the ass here as well.

My first issue started on step 10, when I was running the command.

chown -R bind:bind /var/lib/named/var/*

The directory did not exist. I changed the second var before the /* to dev and the command completed properly.

The issue became more apparent when I restarted Bind and checked the syslog and found numerous errors, basically indicated Bind did not start.


Nov 6 16:15:13 barf named[3719]: found 1 CPU, using 1 worker thread
Nov 6 16:15:13 barf named[3719]: loading configuration from '/etc/bind/named.conf'
Nov 6 16:15:14 barf named[3719]: /etc/bind/named.conf.options:2: change directory to '/var/cache/bind' failed: file not found
Nov 6 16:15:14 barf named[3719]: /etc/bind/named.conf.options:2: parsing failed
Nov 6 16:15:14 barf named[3719]: loading configuration: file not found
Nov 6 16:15:14 barf named[3719]: exiting (due to fatal error)

I went on and tried to install mysql, which I also have poor track record.

The second issue was after setting the sql root password, running this command.

mysqldadmin -h <FQDN> -u root password <password>

The result was 'Lost connection to mysql server during query'. So I tried the computer's IP address in place of FQDN, and all with the same result. This is where I stopped. I need to fix my DNS/Bind settings, but have no clue on how to go about doing that. There is a DNS server already on the LAN, servicing the same zone. I am hoping Ubuntu could replace that machine. Could that be an issue? I cannot see whom my Ubuntu server is using for DNS either.

Any help would be great, thanks...

Reply With Quote
Sponsored Links