View Single Post
  #7  
Old 23rd October 2006, 06:04
jkrell jkrell is offline
Member
 
Join Date: Oct 2006
Posts: 61
Thanks: 6
Thanked 1 Time in 1 Post
Default

Hey Falko:

OK, so I am working through this reverse proxy documentation. There's lots of conflicting info out there. I think I know how to configure httpd.conf (using the details found at http://www.apacheweek.com/features/reverseproxies). However, I am having trouble with getting libxml2.so.2 and/or mod_proxy_html.so to load at startup.

The error I get during startup says: wrong elf class ELFCLASS32

At first, I thought this was something to do with me miscompiling mod_proxy_html using apxs. The command I used was:

# apxs -c -I/usr/include/libxml2 -i mod_proxy_html.c

Now, I think, however, that I have installed the wrong version of libxml2. Is it possible I installed the 32-bit library and not the 64-bit?

Last edited by jkrell; 23rd October 2006 at 06:15.
Reply With Quote