View Single Post
  #1  
Old 18th October 2006, 03:20
shark_tico shark_tico is offline
Junior Member
 
Join Date: Oct 2006
Location: San Ramon, Costa Rica
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default spamassassin stop working after woody to sarge update

Hello

We have a server that was installed with woody and has postfix +
amavis-new + spamassasin + clamav

Everything worked good until postfix got update with sarge packages with apt-get update and after apt-upgrade, when this happened the server stoped working at all.

After a lot of tries and several changes at config files, we decided to make
apt-get dist -upgrade, but with this didn't work, after more changes
postfix began to work, the problem is that the mails aren't marked as SPAM anymore, before the update okeverything was working fine, clamav is working fine

Current Versions (dpkg -l ):
postfix 2.1.5-9 A high-performance mail transport agent
amavisd-new 20030616p10-5 Interface between MTA and virus
scanner/cont
spamassassin 3.0.3-2sarge1 Perl-based spam filter using text analysis
clamav 0.84-2.sarge.9 antivirus scanner for Unix

Config file amavis-new:

# @bypass_spam_checks_acl = qw( . ); # uncomment to DISABLE anti-spam code
$final_spam_destiny = D_PASS;
$spam_quarantine_to = 'spam-quarantine';
$remove_existing_spam_headers = 1;
$sa_tag_level_deflt = 4.0; # add spam info headers if at, or above that
level
$sa_tag2_level_deflt = 6.3; # add 'spam detected' headers at that level
$sa_kill_level_deflt = $sa_tag2_level_deflt; # triggers spam evasive
actions
$sa_spam_subject_tag = '***SPAM*** '; # (defaults to undef, disables)
$sa_spam_modifies_subj = 1; # may be a ref to a lookup table, default is
true


At the log (/var/log/mail.info)

Sep 20 11:11:39 SERVER amavis[4347]: (04347-04) spam_scan: hits=0.528
tests=AWL,HTML_90_100,HTML_MESSAGE,PLING_PLING,UPP ERCASE_25_50
Sep 20 11:11:41 SERVER amavis[4489]: (04489-01) spam_scan: hits=4.111
tests=DATE_IN_FUTURE_03_06,DNS_FROM_RFC_WHOIS,EXTR A_MPART_TYPE,
HELO_DYNAMIC_DIALIN,HTML_40_50,HTML_IMAGE_ONLY_24, HTML_MESSAGE,RCVD_IN_NJABL_DUL,RCVD_IN_SORBS_DUL
Sep 20 11:11:45 SERVER amavis[4489]: (04489-02) spam_scan: hits=0.124
tests=AWL,FORGED_RCVD_HELO,X_PRIORITY_HIGH
Sep 20 11:11:49 SERVER amavis[4347]: (04347-05) spam_scan: hits=3.273
tests=INFO_TLD,RCVD_IN_NJABL_DUL,RCVD_IN_SORBS_DUL ,RCVD_IN_XBL
Sep 20 11:11:51 SERVER amavis[4347]: (04347-06) spam_scan: hits=0.416
tests=EXTRA_MPART_TYPE,HTML_30_40,HTML_MESSAGE,RCV D_IN_SORBS_DUL
Sep 20 11:11:52 SERVER amavis[4347]: (04347-07) spam_scan: not wasting time on SA,
message longer than 65536 bytes: 869+71699
Sep 20 11:11:52 SERVER amavis[4347]: (04347-07) spam_scan: hits=
Sep 20 11:11:57 SERVER amavis[4489]: (04489-03) spam_scan: hits=0.366
tests=HTML_MESSAGE,SUBJ_ALL_CAPS
Sep 20 11:12:05 SERVER amavis[4489]: (04489-04) spam_scan: not wasting time on SA,
message longer than 65536 bytes: 767+610818
Sep 20 11:12:05 SERVER amavis[4489]: (04489-04) spam_scan: hits=
Sep 20 11:12:06 SERVER amavis[4347]: (04347-08) spam_scan: hits=0.695 tests=AWL,
HTML_40_50,HTML_FONT_LOW_CONTRAST,HTML_MESSAGE

Email header's:
Received: from localhost (localhost [127.0.0.1]) by server (Postfix)
with ESMTP id 111FC349A8C; Wed, 20 Sep 2006 11:06:17 -0600 (CST)
Received: from server ([127.0.0.1]) by localhost (server [127.0.0.1])
(amavisd-new, port 10024)
X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at servidor

In some mails appear:
X-Spam: Not Detected.


Thanks in advance for any help, that will be apreciated.
Reply With Quote
Sponsored Links