View Single Post
  #1  
Old 25th September 2006, 22:43
stylez stylez is offline
Junior Member
 
Join Date: Sep 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Load-Balanced MySQL Cluster Error with Cluster

Hello,

I've followed the tutorial on how to setup a load-balanced Mysql Cluster and everything seems to be working fine but just recently as I checked up on the services, one of the mysql-cluster isn't being recognized by ndb_mgm app. I've had this problem twice before and I thought I misconfigured it and reinstall the whole system on VM's, I thought I solved it but it seems to be reoccuring after a few days of completing the setup.

Here is my configuration for the 5 machines: (note all VMs)

sql-1 172.30.0.7 (runs ndbd and mysql)
sq-2 172.30.0.8 (runs ndbd and mysql)
loadb-1 172.30.0.110 (runs lb1 and ndb_mgm) [active]
loadb-2 172.30.0.9 (runs lb2) [passive]

virtual IP for cluster: 172.30.0.111

I can ping the virtual IP, I can access the mysql db's from 0.7 and 0.8 but when I try from 0.111, I get an error trying to connect.

Here's the output from show in ndb_mgm

Cluster Configuration
---------------------
[ndbd(NDB)] 2 node(s)
id=2 @172.30.0.7 (Version: 4.1.21, Nodegroup: 0, Master)
id=3 @172.30.0.8 (Version: 4.1.21, Nodegroup: 0)

[ndb_mgmd(MGM)] 1 node(s)
id=1 @172.30.0.110 (Version: 4.1.21)

[mysqld(API)] 2 node(s)
id=4 (not connected, accepting connect from any host)
id=5 @172.30.0.8 (Version: 4.1.21)


I've restarted mysql on 0.7 and it seems to run fine, but ndb_mgm doesn't see it and even so, 0.8 is running it fine but I still can't connect. Everything worked last week when I completed the setup and I don't know what else I could do to check what may be erroring so that the cluster isn't working. Loadb-1 is the active load-balancers and it should direct the db to sql-2 but it doesn't seem to. I ran all the checks found on http://www.howtoforge.com/loadbalanc...ster_debian_p8 and it all checks out fine and the active loadb-1 has the ip 172.30.0.111 as the virutal. If anyone has experience this or could shed some light on what I might be doing wrong that would be great. As I said, everything work 100% when I completed the inital install and I even tested when a single cluster and load balancer would go down, and it worked as the tutorial stated.
Reply With Quote
Sponsored Links