Thread: proFTP config
View Single Post
Old 22nd September 2006, 15:28
latcarf latcarf is offline
Senior Member
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post

Makes sense... I only want one but I don't want it going to the ISPConfig web15_ user incoming directory. When I log in as anonymous via an ftp client it takes me to the web15_ "root" showing the /incoming directory.

As it stands right now the proftpd_ispconfig.conf file only cites web15_ (see below) even though I also have web14_designated for ftp use. I can however log in with the web15_ or web14 user name and password and get to their directories. That is okay and how it probably should be. I just want anonymous to go to the /srv/ftp and the directories I set up in there.

        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
        <Anonymous /srv/www/web15/ftp>
          User                          web15_anonftp
          Group                         web15_anonftp
          UserAlias                     anonymous web15_anonftp
          UserAlias                     guest web15_anonftp
          MaxClients                    10
          <Directory *>
            <Limit WRITE>
          <Directory /srv/www/web15/ftp/incoming>
            Umask                       002
            <Limit STOR>
            <Limit READ>
the proftpd.conf file is as cited in the Perfect Set Up unless internal changes reconfigured it.

I only have 2 sites (going for 3) so with web"14", "15" you can see I made a few mistakes setting evrything up. I am about to start from scratch with SuSe 10.1 and ISPConfig so hopefully I won't make those mistakes again and maybe it will correct the ftp problems I probably created.
Reply With Quote