View Single Post
  #1  
Old 20th September 2006, 22:15
ACDII ACDII is offline
Member
 
Join Date: Sep 2006
Posts: 95
Thanks: 7
Thanked 4 Times in 4 Posts
Unhappy httpd broken after ISPConfig install

Just did a fresh install of Fedora Core 4, followed http://www.howtoforge.com/perfect_se...dora_core_4_p5 to the letter, followed the installation of ISPConfig, I did make a mistake with the naming at one point by making it www.name.domain.com, and the following line was domain.com. I dont know if that is the root cause, but HTTPD will not start.

Here is the last part of the ./setup

Connected successfully to db db_ispconfig
no crontab for root
Restarting some services...
httpd not running, trying to start
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Shutting down ISPConfig system...
/root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
ISPConfig system stopped!
Starting ISPConfig system...
Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: cannot restore segment prot after reloc: Permission denied
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

Looks as though php is broken, but I didnt have any issues when I installed the services originally, and the web server was working OK until I installed ISPConfig.

Do I need to uninstall it, or what? I am not Savvy with unix, so I would need some walk throughs to uninstall it.
Reply With Quote
Sponsored Links