View Single Post
  #7  
Old 19th September 2006, 16:16
vbrookie vbrookie is offline
Junior Member
 
Join Date: May 2006
Posts: 16
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko
What's the output of
Code:
ls -la /var/lib/named
on both servers? What's in /etc/named.conf on both servers?
Here's the content of first server:ns1
Code:
ns1:~ # ls -la /var/lib/named/
total 64
drwxr-xr-x  9 root  root  4096 Sep 15 14:01 .
drwxr-xr-x 28 root  root  4096 Sep 18 15:30 ..
-rw-r--r--  1 root  root   192 Jul  4  2001 127.0.0.zone
drwxr-xr-x  2 root  root  4096 Sep 14 16:21 dev
drwxr-xr-x  2 named named 4096 May  2 04:33 dyn
drwxr-xr-x  3 root  root  4096 Sep 18 13:26 etc
-rw-r--r--  1 root  root   158 Jul  4  2001 localhost.zone
drwxr-xr-x  2 named named 4096 May  2 04:33 log
drwxr-xr-x  2 root  root  4096 May  2 04:33 master
-rw-r--r--  1 named named  704 Sep 15 14:02 pri.xxx.xxx.xxx.in-addr.arpa
-rw-r--r--  1 named named  673 Sep 15 14:02 pri.xxx.xxx.xxx.in-addr.arpa~
-rw-r--r--  1 named named  814 Sep 18 13:26 pri.example.com
-rw-r--r--  1 named named  843 Sep 18 13:26 pri.example.com~
-rw-r--r--  1 root  root  2517 May  2 04:33 root.hint
drwxr-xr-x  2 named named 4096 May  2 04:33 slave
drwxr-xr-x  4 root  root  4096 Sep  8 11:39 var
ns1:~ #


/etc/named

options {
        pid-file "/var/lib/named/var/run/named/named.pid";
        directory "/var/lib/named";
        auth-nxdomain no;
        allow-recursion {
	localhost;
	};
	/*
         * If there is a firewall between you and nameservers you want
         * to talk to, you might need to uncomment the query-source
         * directive below.  Previous versions of BIND always asked
         * questions using port 53, but BIND 8.1 uses an unprivileged
         * port by default.
         */
        // query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
        type hint;
        file "root.hint";
};

zone "0.0.127.in-addr.arpa" {
        type master;
        file "127.0.0.zone";
};

zone "xxx.xxx.xxx.in-addr.arpa" {
        type master;
        file "pri.xxx.xxx.xxx.in-addr.arpa";
};


zone "example.com" {
        type master;
        file "pri.example.com";
};



//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////
And content of second server: ns2

Code:
ns2:~ # ls -la /var/lib/named/
total 48
drwxr-xr-x  9 root  root  4096 Sep 18 11:13 .
drwxr-xr-x 28 root  root  4096 Sep 18 17:30 ..
-rw-r--r--  1 root  root   192 Jul  4  2001 127.0.0.zone
drwxr-xr-x  2 root  root  4096 Sep 14 13:22 dev
drwxr-xr-x  2 named named 4096 May  2 04:33 dyn
drwxr-xr-x  3 root  root  4096 Sep 18 11:13 etc
-rw-r--r--  1 root  root   158 Jul  4  2001 localhost.zone
drwxr-xr-x  2 named named 4096 May  2 04:33 log
drwxr-xr-x  2 root  root  4096 May  2 04:33 master
-rw-r--r--  1 root  root  2517 May  2 04:33 root.hint
drwxr-xr-x  2 named named 4096 May  2 04:33 slave
drwxr-xr-x  4 root  root  4096 Sep 12 23:17 var
ns2:~ #


/etc/named

options {
        pid-file "/var/lib/named/var/run/named/named.pid";
        directory "/var/lib/named";
        auth-nxdomain no;
        allow-recursion {
	localhost;
	};
	/*
         * If there is a firewall between you and nameservers you want
         * to talk to, you might need to uncomment the query-source
         * directive below.  Previous versions of BIND always asked
         * questions using port 53, but BIND 8.1 uses an unprivileged
         * port by default.
         */
        // query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
        type hint;
        file "root.hint";
};

zone "0.0.127.in-addr.arpa" {
        type master;
        file "127.0.0.zone";
};



zone "example.com" {
        type slave;
        file "sec.example.com";
        masters { 192.168.1.100; };
};


//// MAKE MANUAL ENTRIES BELOW THIS LINE! ////
Thanks!
Reply With Quote