Thread: suEXEC problem
View Single Post
  #1  
Old 18th September 2006, 07:10
rbartz rbartz is offline
Member
 
Join Date: Apr 2006
Posts: 80
Thanks: 9
Thanked 6 Times in 5 Posts
Default suEXEC problem

I turned on suEXEC today, and tried the test script, test.pl in the cgi-bin directory. It returned 500 server errors. When I looked in /var/log/httpd/suexec.log I found:

[2006-09-17 21:13:44]: directory is writable by others: (/var/www/web35/cgi-bin)
[2006-09-17 21:13:40]: uid: (10074/richard1) gid: (10038/10038) cmd: test.pl

ll of the ..../web38 dir gave
drwxrwxr-x 2 richard1 web38 4096 Sep 17 21:17 cgi-bin

By chmoding the cgi-bin from 0775 to 0755 the problem is solved, the script runs without error.

The directory is owned by the user and group. I see that suEXEC will not run if the directory is owned by any other, but that is not the case. Surely someone has run into this.

If I change the permissions on the cgi-bin will they stay at 755? Why are they 775 to begin with, does ispConfig have some reason for this?

Thanks

RDB
Reply With Quote
Sponsored Links