View Single Post
Old 13th September 2006, 16:42
qtam0 qtam0 is offline
Junior Member
Join Date: Sep 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Post SuExec compiling


I have a homeserver, which has apache 2.0.54 as webserver. I've installed fastcgi and compiled php5 to run as FastCGI.

I've tried to get fastcgi use suexec wrapper mechanism. It does work, but only on my primary web-address (
My vhosts are set so that /www/ is docroot for the primary address, and /www/ is for vhost1 /www/ for vhost2 etc.

Because I want FastCGI to use suexec, I used this howto:
and complied php and suexec (I didn't edit suexec.c, because I want suexec to check file owner).

But there's a problem on suexec compile, when I do "./suexec -V" after "make suexec" it says:

-D AP_DOC_ROOT="/var/www"
-D AP_HTTPD_USER="www-data"
-D AP_LOG_EXEC="/var/log/apache2/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_USERDIR_SUFFIX="public_html"
even if I modified suexec.h like:

replaced with
#define AP_DOC_ROOT "/www"

before "make suexec". I even tried to edit ap_config_layout.h so that #define DEFAULT_EXP_HTDOCSDIR "/www"
but it didn't help. After make it still says "-D AP_DOC_ROOT="/var/www""

The reason why my primary domain works is (or I think it is...) that I have symlinked /var/www to /www/ like this:
server:/var# ls -l www
lrwxrwxrwx 1 root root 17 2006-09-09 22:26 www -> /www/
Does anyone know why settings from suexec.h won't apply?

ps. sorry about my bad english, I tried to make it understandable

Last edited by qtam0; 13th September 2006 at 16:45.
Reply With Quote
Sponsored Links