View Single Post
  #1  
Old 13th September 2006, 08:56
ozonblue ozonblue is offline
Junior Member
 
Join Date: Aug 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default .htaccess login challenge broken with mod_rewrite

Hi all.

I'm running ISPconfig on Debian Sarge with perfect setup.

I'm using the WebGUI content management system on some virtual hosts which rewrites some URL's - *excluding* the /stats/ directory which is protected by ISPconfig's .htaccess file.

When I remove that .htaccess file everything works fine - which tells me that mod_rewrite is working correctly. When the .htaccess file is present - I get an unauthorised access message - but the login challenge dialog box doesn't pop up as it does on the virtual hosts without the rewrite rules.

I try to delete the .htaccess file in the /stats/ directory - the problem is that ISPconfig keep on automatically adding that .htaccess file.

I'm sure it is a issue with mod_rewrite not working well with .htaccess - perhaps somebody has a bit of advice ?

Here is the rewrite rules from my "optional" Apache directives setting.

**********************************************
<Files ~ '.(pl)$'>
SetHandler perl-script
PerlHandler ModPerl::Registry
</Files>
RewriteEngine On
RewriteRule ^/extras/ - [L]
RewriteRule ^/env.pl - [L]
RewriteRule ^/uploads/ - [L]
RewriteRule ^/stats/ - [L]
RewriteRule ^/images/ - [L]
RewriteRule ^/images_files/ - [L]
RewriteRule ^/extras/ - [L]
RewriteRule ^/(.*) /index.pl/$1
*****************************************
Reply With Quote
Sponsored Links