View Single Post
  #1  
Old 5th September 2006, 15:33
shiidii shiidii is offline
Member
 
Join Date: Jul 2006
Location: Melbourne, Australia
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Cannot receive emails : DSN: User Unknown

Hi, I'm running an Ubuntu Dapper Drake server with ispconfig installed.

I have been trying to overcome this problem for quite a while and I feel that I'm nearly there.
I have setup email accounts on my server through ISPCONFIG and I can log into them with Outlook Express. However whenever I try to send an email to the account I get bounced back with unknown user
here is the mail log sent with www-data:

Code:
Sep  5 21:33:02 mailserver sm-mta[32024]: k85BX1Nr032023: to=<www-data@mailserver.mydomain.com>, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=32639, dsn=2.0.0, stat=Sent
Sep  5 21:35:26 mailserver sendmail[32130]: k85BZQ74032130: from=www-data, size=260, class=0, nrcpts=1, msgid=<200609051135.k85BZQ74032130@mailserver.mydomain.com>, relay=www-data@localhost
Sep  5 21:35:26 mailserver sm-mta[32131]: k85BZQHP032131: <sales@mydomain.com>... User unknown
Sep  5 21:35:26 mailserver sendmail[32130]: k85BZQ74032130: to="Test - Sales@aaapaints User" <sales@mydomain.com>, ctladdr=www-data (33/33), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30260, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown
Sep  5 21:35:26 mailserver sm-mta[32131]: k85BZQHP032131: from=<www-data@mailserver.mydomain.com>, size=260, class=0, nrcpts=0, proto=ESMTP, daemon=MSP-v4, relay=localhost [127.0.0.1]
Sep  5 21:35:26 mailserver sendmail[32130]: k85BZQ74032130: k85BZQ75032130: DSN: User unknown
This is the Postfix Main.cf in full

Code:
myhostname = mailserver.mydomain.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mailserver.mydomain.com, localhost.example.com, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
mailbox_command = procmail -a "$EXTENSION"
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = no
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

# modify the existing smtpd_recipient_restrictions
smtpd_recipient_restrictions = reject_unauth_pipelining, permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_recipient, reject_unauth_destination, check_policy_service inet:127.0.0.1:60000, permit
# modify the existing smtpd_sender_restrictions
smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_non_fqdn_sender, reject_unknown_sender_domain, reject_unauth_pipelining, permit
# then add these
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain =

content_filter = amavis:[127.0.0.1]:10024
#receieve_override_options = no_address_mappings

virtual_maps = hash:/etc/postfix/virtusertable

mydestination =

# not sure of the difference of the next two
# but they are needed for local aliasing
alias_maps = hash:/etc/postfix/aliases
alias_database = hash:/etc/postfix/aliases
# this specifies where the virtual mailbox folders will be located
virtual_mailbox_base = /var/spool/mail/virtual
# this is for the mailbox location for each user
virtual_mailbox_maps = mysql:/etc/postfix/mysql_mailbox.cf
# and their user id
virtual_uid_maps = mysql:/etc/postfix/mysql_uid.cf
# and group id
virtual_gid_maps = mysql:/etc/postfix/mysql_gid.cf
# and this is for aliases
virtual_alias_maps = mysql:/etc/postfix/mysql_alias.cf
# and this is for domain lookups
virtual_mailbox_domains = mysql:/etc/postfix/mysql_domains.cf
# this is how to connect to the domains (all virtual, but the option is there)
# not used yet
# transport_maps = mysql:/etc/postfix/mysql_transport.cf

masquerade_domains = aaa-paints.mydomain.com !aaa-paints.mydomain.com
masquerade_exceptions = root

# Requirements for the HELO statement
smtpd_helo_restrictions = permit_mynetworks, warn_if_reject reject_non_fqdn_hostname, reject_invalid_hostname, permit
# Requirements for the sender details
smtpd_sender_restrictions = permit_mynetworks, warn_if_reject reject_non_fqdn_sender, reject_unknown_sender_domain, reject_unauth_pipelining, permit
# Requirements for the connecting server smtpd_client_restrictions = reject_rbl_client sbl.spamhaus.org, reject_rbl_client relays.ordb.org, reject_rbl_client blackholes.easynet.nl, reject_rbl_client dnsbl.njabl.org
# Requirement for the recipient address smtpd_recipient_restrictions = reject_unauth_pipelining, permit_mynetworks, reject_non_fqdn_recipient, reject_unknown_recipient_domain, reject_unauth_destination, permit

# require proper helo at connections
smtpd_helo_required = yes
# waste spammers time before rejecting them
smtpd_delay_reject = yes
disable_vrfy_command = yes
I'm sure there's something wrong in here.

Here is the ouput of "ls -la /root/ispconfig"

Code:
total 112
drwxr-xr-x  9 root root  4096 2006-09-05 21:20 .
drwxr-xr-x 11 root root  4096 2006-09-05 22:13 ..
-rwxr-xr-x  1 root root 45996 2006-07-06 12:26 cronolog
-rwxr-xr-x  1 root root  9673 2006-07-06 12:26 cronosplit
drwxr-xr-x 12 root root  4096 2006-07-06 12:09 httpd
drwxr-xr-x 12 root root  4096 2006-07-06 12:26 isp
-rw-r--r--  1 root root     9 2006-09-05 21:20 .old_path_httpd_root
drwxr-xr-x  6 root root  4096 2006-07-06 11:59 openssl
drwxr-xr-x  6 root root  4096 2006-07-18 01:56 php
drwxr-xr-x  4 root root  4096 2006-07-06 12:26 scripts
drwxr-xr-x  4 root root  4096 2006-07-06 12:26 standard_cgis
drwxr-xr-x  2 root root  4096 2006-07-06 12:26 sv
-rwx------  1 root root  9389 2006-07-06 12:26 uninstall
I do have a codomain for my website with an empty host, which often is the problem for a lot of people. Also my virtusertable and local-host-names files are configured correctly
Maildir is enabled in ISPCONFIG

Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
mailserver.mydomain.com
localhost.mailserver.mydomain.com
localhost.mydomain.com
www.mydomain.com
mydomain.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
Code:
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
sales@www.mydomain.com    web1_sales
web1_sales@www.mydomain.com    web1_sales
sales@mailserver.mydomain.com    web1_sales
web1_sales@mailserver.mydomain.com    web1_sales
sales@mydomain.com    web1_sales
web1_sales@mydomain.com    web1_sales
user@www.mydomain.com    web1_user
web1_user@www.mydomain.com    web1_user
user@mailserver.mydomain.com    web1_user
web1_user@mailserver.mydomain.com    web1_user
user@mydomain.com    web1_user
web1_user@mydomain.com    web1_user
user2@www.mydomain.com    web1_user2
web1_user2@www.mydomain.com    web1_user2
user2@mailserver.mydomain.com    web1_user2
web1_user2@mailserver.mydomain.com    web1_user2
user2@mydomain.com    web1_user2
web1_user2@mydomain.com    web1_user2
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
I just can't seem to pin point where this is going wrong. The only problem is the incoming emails. I can log into the user accounts and send emails fine with outlook.
Thanks heaps for any help you have.

Last edited by shiidii; 7th January 2007 at 10:28.
Reply With Quote
Sponsored Links