View Single Post
  #15  
Old 5th September 2006, 04:12
naruto naruto is offline
Junior Member
 
Join Date: Aug 2006
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Solved

I solved all issues !!!!!

This is what I found. (Maybe it is obvious but might help someone)

When I first intalled debian, I used a i386 distribution of the net install and then I changed my kernel to one
who could fit my 64 bit hardware system configuration.

This is called 32 bit userspace in a 64 bit kernel, which often gives lots of conflicts until you recompile your kernel, or force some 32 bit
behaviour of the programs installed. (I need to aplied both to make work openssl and iptables)

Another solution (which I didn't test) is to install affected programs, from a 64 bit distribution apt source (e.g: http://ftp.us.debian.org/debian-amd64/) or
from the amd64 site (amd64.debian.net)

Maybe works but probably you'll get some errors at download (apt-get) because they are marked as unstable.


As conclusion, upgrading to a 64 bit kernel doesn't change your first system architecture -i386, (Maybe is possible but can't find how) unless
you start with a 64 bit distribution. When you have everyting running in 64 bit no conflicts appear and everything goes just fine.

This is what I did and after a good installation, I followed falko's debian how to and Ispconfig manual with no errors. (dns, mail, ftp access, php,
webmail (squirrel, uebimiau), user access...everything what I've tested so far, is working as expected)

Unfortunately, having a good install from a amd64 net install wasn't as easy as i386. Whole distribution is marked as unstable and when downloading files
with apt, it shows some errors. You must do some tricks to let apt works (at least in my case)


Just to help those recompiling a debian kernel, I followed falko's how to with some important notes found here: http://www.linuxquestions.org/questi...d.php?t=206992

It says that you must use debian kernel source instead of general sources because debian includes some special patches. Also I used the command --intrd
(refer to the above link ) because falko's way to compile didn't generate a intrd.img file.
I tried to use the latest i386 general source kernel with no positive solutions. After using debian kernel source it works.



Nice to see falko and till's opinions about this. Maybe they can add something or just correct me if this is wrong.

Thanks for your help and for your great system Till and Falko.


Hope this could aid someone.
Reply With Quote