View Single Post
  #23  
Old 4th September 2006, 21:36
jjw jjw is offline
Member
 
Join Date: Aug 2006
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Allrighty,

I've done yet another reinstall (taking default on certificate building). I've *not* checked Maildir (using mbox format), and I am getting the CTX messages when using a client with SSL (not secure authentication):
Code:
Sep  4 13:59:13 mail ipop3d[3933]: Unable to load certificate from /usr/share/ssl/certs/ipop3d.pem, host=[192.168.0.13]
Sep  4 13:59:13 mail ipop3d[3933]: SSL error status: error:02001002:system library:fopen:No such file or directory
Sep  4 13:59:13 mail ipop3d[3933]: SSL error status: error:20074002:BIO routines:FILE_CTRL:system lib
Sep  4 13:59:13 mail ipop3d[3933]: SSL error status: error:140DC002:SSL routines:SSL_CTX_use_certificate_chain_file:system lib

Nothing at all happens when I uncheck "Secure Authentication" *and* SSL, and nothing happens when "Secure Authentication" is checked.

netstat -tap (using xinetd services for pop3/s imap/s:
Code:
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:imaps                     *:*                         LISTEN      1998/xinetd
tcp        0      0 *:32769                     *:*                         LISTEN      1632/rpc.statd
tcp        0      0 *:pop3s                     *:*                         LISTEN      1998/xinetd
tcp        0      0 *:mysql                     *:*                         LISTEN      2092/mysqld
tcp        0      0 *:pop3                      *:*                         LISTEN      1998/xinetd
tcp        0      0 *:imap                      *:*                         LISTEN      1998/xinetd
tcp        0      0 *:sunrpc                    *:*                         LISTEN      1614/portmap
tcp        0      0 *:81                        *:*                         LISTEN      2415/ispconfig_http
tcp        0      0 mail.wnetworks.net:domain   *:*                         LISTEN      3083/named
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      3083/named
tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      1941/cupsd
tcp        0      0 localhost.localdomain:5335  *:*                         LISTEN      1923/mDNSResponder
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      3083/named
tcp        0      0 *:smtp                      *:*                         LISTEN      3058/master
tcp        0      0 mail.wnetworks.net:35977    host-213-160-98-160.tc:http TIME_WAIT   -
tcp        0      0 *:http                      *:*                         LISTEN      2985/httpd
tcp        0      0 *:ftp                       *:*                         LISTEN      3099/proftpd: (acce
tcp        0      0 *:ssh                       *:*                         LISTEN      1989/sshd
tcp        0      0 *:https                     *:*                         LISTEN      2985/httpd

So, I decided to disable the xinetd service for imap/imaps & pop3/pop3s, and enable dovecot. I then restart the server completely.

I then log in with the email client, using SSL (not Secure Authentication), and am successful:

/var/log/dovecot:
Code:
dovecot: Sep 04 14:07:49 Info: Dovecot starting up
pop3-login: Sep 04 14:11:42 Info: Login: web1_test5 [192.168.0.13]
netstat -tap (using Dovecot):
Code:
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:imaps                     *:*                         LISTEN      2080/dovecot
tcp        0      0 *:32769                     *:*                         LISTEN      1632/rpc.statd
tcp        0      0 *:pop3s                     *:*                         LISTEN      2080/dovecot
tcp        0      0 *:mysql                     *:*                         LISTEN      2059/mysqld
tcp        0      0 *:pop3                      *:*                         LISTEN      2080/dovecot
tcp        0      0 *:imap                      *:*                         LISTEN      2080/dovecot
tcp        0      0 *:sunrpc                    *:*                         LISTEN      1614/portmap
tcp        0      0 *:81                        *:*                         LISTEN      2397/ispconfig_http
tcp        0      0 mail.wnetworks.net:domain   *:*                         LISTEN      3032/named
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      3032/named
tcp        0      0 localhost.localdomain:ipp   *:*                         LISTEN      1908/cupsd
tcp        0      0 localhost.localdomain:5335  *:*                         LISTEN      1890/mDNSResponder
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      3032/named
tcp        0      0 *:smtp                      *:*                         LISTEN      3007/master
tcp        0      0 *:http                      *:*                         LISTEN      2935/httpd
tcp        0      0 *:ftp                       *:*                         LISTEN      3048/proftpd: (acce
tcp        0      0 *:ssh                       *:*                         LISTEN      1956/sshd
tcp        0      0 *:https                     *:*                         LISTEN      2935/httpd
But I cannot login using 'Secure Authentication', nor can I log in with both options unchecked (SSL & Secure Authentication). the logs are empty and the client times ot.

This is driving me crazy.

So, I tried sending email. With SSL checked in connection, I tried to send an email to remoteEmail@domain.tld (I used a real address that accepts mail from my other mail server on my LAN). I tried using both TLS and SSL in the outgoing SMTP server settings:

using 'TLS, if available'

Quote:
An error occured while sending mail. The mail server responded: <remoteEmail@domain.tld>; Relay access denied. Please verify that your email address is correct in your Mail preferrences and try again.

using 'SSL'


Quote:
Sending of message failed.

The message could not be sent because conneting to server 192.168.0.10 failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server setting is correct and try again, or else contact your network administrator.
This is really killing my sleep.
Reply With Quote