Thread: x84_64
View Single Post
  #19  
Old 8th October 2005, 21:00
gbjbaanb gbjbaanb is offline
Junior Member
 
Join Date: Aug 2005
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default CentOS 4.1 64bit

OK. I trashed my old ISPConfig install and installed v2.09.

It recognises CentOS 4.1 64bit now, but it still does not compile.

To get installed, you will need to install the ssl-devel package.

Then you will need to edit the compile script (in compile_aps directory) to use the local openssl libraries, and the 64-bit zlib libraries:
Code:
cd ../${PHP}
./configure --with-apxs=${INSTALL_ROOT}/httpd/bin/apxs --enable-track-vars --enable-sockets --with-config-file-path=${INSTALL_ROOT}/php --enable-ftp --prefix=${INSTALL_ROOT}/php --with-openssl --with-mysql=/usr/local/lib/mysql --disable-libxml --with-zlib-dir=/usr/lib64 || error "Could not configure PHP"
then, you need to follow the steps described here: http://www.howtoforge.com/forums/sho...0&postcount=12 to get around the mysql bug.

Code:
Before starting the installtion process do this, because mysql has a bug in the x86_64 which can only be fixed so.
mkdir /usr/local/lib/mysql
and create symlinks "include" and "lib" pointing to the original directories (here /usr/include/mysql and /usr/lib64/mysql)
cd /usr/local/lib/mysql
ln -s /usr/include/mysql include
ln -s /usr/lib64/mysql lib
Reply With Quote