View Single Post
  #3  
Old 29th August 2006, 03:51
sasUse sasUse is offline
Junior Member
 
Join Date: Aug 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default configuration of DNS and WWW

Hi Falko,

Thanks for replying and am sorry to get back to you late as i had a lot of work and also my birthday...but here it is

Under my registrars control panel, i changed my domain name webhostingfx.com.au to have a DNS with ns1.webhostingfx.com.au. Now as this server is not available publicly i understand that i would need to create the server which is the one i am configuring.

Now, under applications -> System Settings -> Network -> DNS (tab) settings are:
Hostname: server1.webhostingfx.com.au
webhostingfx.com.au is the registered domain name so i put server1.webhostingfx.com.au
Primary DNS: is fine (from my provider)
Secondary DNS: is fine (from my provider)
I am unsure about this one
DNS Search Path: it was server1.com but i changed it to server1

Now, under applications -> System Settings -> Network -> hosts (tab) settings are:
IP: 192.168.0.2 (lan IP)
Name: server1.webhostingfx.com.au
Aliases: server1

I hope so far so good

Now the ISP_CONFIG configuration
I configured the DNS according to the link that you sent me.
But here is what i have under DNS manager
In the tree menu there is a webhostingfx.com.au, when i click on that i get the settings window in the right column
Group: Admin
Title: webhostingfx.com.au
Folder: Admin

Now under the Domain tab:
Server: Server 1
Domain(SOA): webhostingfx.com.au
IP Address: 210.xxx.xxx.xxx

Under the Options tab
Nameserver 1: ns1.webhostingfx.com.au

I don't have another ip, so i don't know if i can configure ns2.webhostingfx.com.au...can I? As this is an ADSL connection and i have only one static IP

Under the Records tab
A Record has
210.xxx.xxx.xxx www
210.xxx.xxx.xxx mail

C Name does not have anything, and MX has
mai.webhostingfx.com.au

Under management -> settings -> server
Server Name: Server 1
Hostname: www
Domain: server1.webhostingfx.com.au
IP Address: 210.xxx.xxx.xxx
Netmask: 255.255.255.0
IP List: 192.168.0.2

Under management -> settings -> DNS
Defaulst ns1: ns1.webhostingfx.com.au
I haven't put in the rest of the fields, i think that's not necessary right now...

And for the ifconfig output:

[root@server1 ~]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:0D:61:4F:06:71
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20d:61ff:fe4f:671/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1277 errors:0 dropped:0 overruns:0 frame:0
TX packets:1339 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:708218 (691.6 KiB) TX bytes:215853 (210.7 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6030 errors:0 dropped:0 overruns:0 frame:0
TX packets:6030 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7042340 (6.7 MiB) TX bytes:7042340 (6.7 MiB)

For the netstat-tap output:
[root@server1 ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address Stat e PID/Program name
tcp 0 0 *:32769 *:* LIST EN 2271/rpc.statd
tcp 0 0 *:mysql *:* LIST EN 2602/mysqld
tcp 0 0 *:sunrpc *:* LIST EN 2251/portmap
tcp 0 0 *:81 *:* LIST EN 3109/ispconfig_http
tcp 0 0 server1.webhostingfx:domain *:* LIST EN 5398/named
tcp 0 0 localhost.localdomai:domain *:* LIST EN 5398/named
tcp 0 0 *:ftp *:* LIST EN 3243/proftpd: (acce
tcp 0 0 localhost.localdomain:ipp *:* LIST EN 2421/cupsd
tcp 0 0 localhost.localdomain:rndc *:* LIST EN 5398/named
tcp 0 0 *:smtp *:* LIST EN 5357/master
tcp 0 0 *:imaps *:* LIST EN 2404/dovecot
tcp 0 0 *:imap *:* LIST EN 2404/dovecot
tcp 0 0 *:http *:* LIST EN 3133/httpd
tcp 0 0 *:ssh *:* LIST EN 2476/sshd
tcp 0 0 localhost:rndc *:* LIST EN 5398/named
tcp 0 0 *:smtp *:* LIST EN 5357/master
tcp 0 0 *:https *:* LIST EN 3133/httpd

I hope that helps, and thanks a lot once again...
sasUse
Reply With Quote